1

not sure why I'm having this issue but I can't add vagrant boxes.

Using windows 10, tried on powershell and simple command prompt. same issue. It's a relatively fresh install of windows. Maybe I'm missing some required package?

first i tried this command:

vagrant box add hashicorp/precise32

and got the error:

The box 'hashicorp/precise32' could not be found or
could not be accessed in the remote catalog. If this is a private
box on HashiCorp's Atlas, please verify you're logged in via
`vagrant login`. Also, please double-check the name. The expanded
URL and error message are shown below:

URL: ["https://atlas.hashicorp.com/hashicorp/precise32"]
Error:

So I downloaded the box manually and tried this:

vagrant box add base64 file:///D:/downloads/vagrant_boxes/precise64.box

And got this error again:

==> box: Box file was not detected as metadata. Adding it directly...
==> box: Adding box 'base64' (v0) for provider:
    box: Unpacking necessary files from: file:///D:/downloads/vagrant_boxes/precise64.box
    box:
An error occurred while downloading the remote file. The error
message, if any, is reproduced below. Please fix this error and try
again.
1

Found the answer here: https://github.com/mitchellh/vagrant/issues/6754#issuecomment-169984218

Need to install Microsoft Visual C++ 2010

Above git forum has the link to the needed download

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.