5

I'm unable to boot Windows 10 installer from an original usb thumb drive (from Windows 10 Home FPP package we just bought) on our machine.

On one hand, our machine is a bit old already:

  • motherboard: Gigabyte GA-EP31-DS3L
  • bios: Award (version F5F) (so no UEFI is involved)

on the other hand it matches all major requirements stated in official windows 10 overview and I don't see any obvious reason why such hw would be no longer supported.

First of all I would like to point out that the problem is not caused by wrong bios boot configuration. I booted Fedora Installer from usb thumb drive on the machine without any problems, then I turned the machine off and replaced linux usb stick with windows 10 one (so that the same usb port and bios configuration is used) and it didn't work.

See the error message I got when trying to boot Windows 10 usb media:

Invalid partition table

It suggests that mbr bootloader (the executable stored in mbr of win 10 usb media) has been actually executed, as the same error message can be found in the mbr data:

$ hexdump -C win10.mbr | grep '^000001[67]0'
00000160  24 02 c3 49 6e 76 61 6c  69 64 20 70 61 72 74 69  |$..Invalid parti|
00000170  74 69 6f 6e 20 74 61 62  6c 65 00 45 72 72 6f 72  |tion table.Error|

Which makes me think that bios did start the bootloader, but it must have failed very early in the boot process for some reason. Unfortunately the error message is not very clear as the partition table looks fine to me:

$ fdisk -l win10.mbr
Disk win10.mbr: 512 B, 512 bytes, 1 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x00000000

Device     Boot Start      End  Sectors  Size Id Type
win10.mbr1 *     2048 30728191 30726144 14.7G  c W95 FAT32 (LBA)

Moreover I was able to boot it on another machine (an old laptop) to check that the windows 10 usb is fine and bootable (I didn't try to run the installation here though, I just checked if it boots). So the media bootloader seems to be fine after all.

So at this point it's quite clear that our bios/motherboard hates our new Windows 10 usb stick.

To find out if this compatibility issue lies in the usb thumb drive itself (hardware) or in windows 10 bootloader (software), I tried to clone the win 10 drive into another usb stick (which previously successfully booted with Fedora Linux on our machine). This cloned windows stick failed to boot on our machine and then booted fine on old laptop, which means that the issue is in the software side of windows 10 bootloader.

Other things I have tried and failed so far:

  • updated bios (from F3 to F5F) with no effect
  • download windows 10 iso from microsoft site which booted fine, but our product key can't be used with it, edit: here I did a mistake when selection edition of iso file, see my answer below

So to sum it up:

  • it seems that windows 10 bootloader from official usb media is broken/incompatible with our machine
  • we can't boot windows 10 usb stick it as it has been purchased

The only solution I can come up with now is to create iso image from our windows 10 usb drive so that we can boot from dvd instead. How to do this so that it would be both straightforward and legal?

With all this in mind, I would also like to know what is the good windows way, Microsoft preferred, approach to solve this. Replacement of any hw component doesn't count.

I wasn't able to find reasonable suggestion (official Microsoft service or tool) or documentation, even when googling wiht site:microsoft.com or searching on support.microsoft.com.

Additional questions I have:

  • How can I verify that the usb thumb drive contains valid data so that I can rule out a bad media option without the need to actually boot it? I mean something like sha checksums of the media or files on it as it's usually done with linux distributions.
  • What does the puzzling Invalid parition table error even mean here? Where can I find documentation for the bootloader?
  • Since this looks like a blatant bug in the windows 10 bootloader, where is the right place to complain about it? (If everything fails, I will return this product back to the retailer, but this is the very last step and I would like to complain about this to someone else as well)

Interesting related google results:

1

Ok, I make it boot after all and it turns out I did a mistake during selection of iso file to download.

While the bootloader on Windows 10 usb medium is a piece of crap, Windows 10 iso file provided by Microsoft should work - one just needs to pay attention to which version to download.

So for Windows 10 Home CZ FPP product we purchased, we should have downloaded Windows 10 edition. I was confused by missing description of each edition of iso file and the fact that our package sais czech edition which made me try Windows N edition allegedly targetted to EU market first. Sigh.

0

I had the same issue.

I solved it by:

  • attaching the hard disk to another computer
  • made a partition on it using Minitool Partition Wizard
  • used NT 6.x Fast Installer to extract Windows sources\install.wim file onto that partition.

Even though NT 6.x Fast Installer is supposed to set the partition you tell it active, I had a minor glitch that after trying to boot from it the system would not start. I solved it by setting the partition as active in Minitool Partition Wizard. For some reason NT 6.x Fast Installer failed to do that. Maybe because this time I had the hard drive attached via USB.

Credit: https://superuser.com/a/914188/68339

0

I had the same issue from my custom multiboot usb, on my Dell Latitude E6330. When you get to "Invalid partition table", just press enter, and it got me to GRUB. You might be able to get the windows installer the same way.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.