11

Windows 10 is commenting out my hosts file entries. This happens periodically so every 1 hour.

Although I manage to save the changes but they will be commented out after around 1 hour.

I never experienced such thing on any Windows version before so maybe there is something I need to do in Windows 10 to prevent this from happening.

I have Bitdefender Total Security 2016 installed.

10

Sul,

Cause: Bitdefender Total Security 2016 is causing this problem

Fix: Right click on hosts file, properties, security, give only read access to "ALL APPLICATION PACKAGES" user/group.

Reference: http://www.bitdefender.com/security/hosts-file-hijacking-becomes-impossible-in-windows-8.html

  • "ALL APPLICATION PACKAGES" has read and read & execute permission. I am unable to change them as they are grayed out. I can deny read & execute but this in turn will deny ready – Sul Aga Dec 26 '15 at 23:21
  • 4
    Sul, On the top right, hit Human icon, hit "General Settings", then "Advanced", takeoff selected flag on "Scan host files" – Ravi Kumar Lachubukta Mar 27 '16 at 2:20
26

To prevent the hosts entries from being commented out by Bitdefender 2016 do the following:

In the main Bitdefender interface click on the human icon (from the upper right corner) and choose General Settings > Advanced tab > "Scan hosts file" button.

Screenshot of this option

  • 1
    Could you possibly include a screenshot of this option? – Burgi May 8 '16 at 13:51

protected by Community Apr 9 '18 at 5:21

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.