1

I'm using VMWare Fusion 7.1 on Mac OS X. All the VM's that I've downloaded connect to the internet automatically when I fire them up. I downloaded a new VM from VulnHub, specifically BrainPan2. (Here is the info about it if needed: https://www.vulnhub.com/entry/brainpan_2,56/)

This one does not connect to the internet automatically even though it is supposed to. It is a vulnerable VM setup for security penetration testing. Now, I fire up my Kali VM, do a network scan, and see all my computers. I'll fire up an unrelated virtual machine, run the scan again, and confirm that the new one appears. Now, I fire up BrainPan, run the scan, and nothing. I don't see it on the scan.

I've read multiple guides related to the BrainPan2 VM from the internet, and everyone else seems to be able to plug it in and go. From the BrainPan site:

It will get an IP address via DHCP,

So, I've set the VM to run on NAT, Bridged and also Host. I cannot detect the VM by any means, it just doesn't auto-connect. And I obviously can't login and hook it up since it's made to hack. Upon my research, I've found another similar question on this site but the gentleman provided no info in his question: Can't get nmap info from Brainpan2

Does anyone have any suggestions?

Edit: It states in this article: http://blog.techorganic.com/2013/11/19/brainpan-2-hacking-challenge/

Brainpan 2 has been tested and found to work on the following hypervisors:

VMware Player 6.0.1 , VMWare Fusion 6.0.2 , VirtualBox 4.3.2 Import

brainpan2.ova into your preferred hypervisor and configure the network settings to your needs. It will get an IP address via DHCP, but it's recommended you run it within a NAT or visible to the host OS only since it is vulnerable to attacks.

I'm on VMWare Fusion 7.1.x, could that be the issue?

  • Can you login to the VM and check to make sure it is getting an IP address? Just because it says it should automatically get an ip via DHCP, does not mean that whomever developed the VM might have decided to disable the adapter until you go in and enable it for the first time. Just throwing ideas out there – Richie086 Dec 26 '15 at 18:38
  • Also for situations like yours, unless the Kali Install is also a VM running via virtual box on the same computer as the VM you are having issues with, you will probably want to use bridged mode for your adapter otherwise you will not be able to see the VM from any machine on your network. NAT mode introduces a whole new subnet for communications between VMs. – Richie086 Dec 26 '15 at 18:42
  • @Richie086 Unfortunately I can only login as a guest user, and it didn't assign anything in that scenario. That is really good to know! Thank you. I'm running Kali as a VM on NAT currently and have been for a while, should I keep it that way? – Henry F Dec 26 '15 at 18:56
  • 1
    Lucky for you virtual box is free! Let me know if that works and if it does I will convert my comment into an answer so if someone else has a similar issue it can be resolved. – Richie086 Dec 26 '15 at 19:48
  • 1
    Done. Glad I was able to help! – Richie086 Dec 26 '15 at 20:27
2

This is a consolidation of the comment stream above.

Jons issue was that he was using the wrong type of network adapter inside of VMware. The VM in question was not receiving an IP address so when he would go to scan it using nmap, he was not seeing the virtual machine.

The solution was to make sure both VM's we're using NAT instead of bridged mode so they could communicate with each other each other.

  • Thank you so much for the help and knowledge that you have provided Richie! – Henry F Dec 26 '15 at 20:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.