16

When I try to save a file, the default extension is All types (*.*). It basically saves it without an extension, for example, just new 1 instead of new 1.txt.

“Default language” option in Settings → Preferences → New Document is set to “Normal Text”.

I Googled and saw that you can change the default save extension in langs.xml.

I've opened it but as far as I've understood the .txt file extension is already set as a default extension:

<Language name="normal" ext="txt" />

What do I do to make the default extension .txt?

Screenshots:

The “New document” settings menu:

The “New Document” settings menu

Trying to save the file and it wants to save to All types (*.*), not as Normal text:

“Save As” dialog

2
  • sad this is still broken 4 years later
    – dangel
    Dec 4, 2019 at 1:40
  • Ignore the answers below. This issue was fixed in version 7.8.7, so there's no reason to revert to the older save dialog. If you're still having this issue, try updating Notepad++. Mar 20, 2021 at 7:09

7 Answers 7

21

Version v7.8.7 of Notepad++ fixed this issue, so try updating Notepad++.


If you need to use an older version of Notepad++ for some reason, you can avoid this issue by switching to the older save dialog prompts (this worked on versions 7.3.2, 7.3.3. and 7.4.2):

Settings->Preferences->Default Directory->uncheck Use new style save dialog…

(Source) Posted by (Claudia Frank)

3
  • Note: The issue was fixed in version 7.8.7, so this is no longer necessary. Try updating Notepad++ instead. Mar 20, 2021 at 7:09
  • Sadly the fix broke something else. Now you can't save with an extension that's not on Notepad++'s "approved list". It will append .txt to such extensions... Actually, in the giant dropdown list of "Save as Type" there is an option for *.*, but it's pretty hard to find.
    – Fizz
    Jan 5 at 15:07
  • Giant thread about the latter issue github.com/notepad-plus-plus/notepad-plus-plus/issues/8398 The dev's (bad) conclusion/reasoning was: "Notepad works like this". But Notepad was really only meant for one type of files.. so appending the default extension in multi-language editor like N++... a bad idea. At least they kept github.com/notepad-plus-plus/notepad-plus-plus/issues/8616 open, which is about the (un)usability of always manually selecting *.* in the ginormous list.
    – Fizz
    Jan 5 at 15:14
23

New style save dialog has to be set to disabled for file extension suffix to work.

  1. Menu » Settings » Preferences
  2. "Default Directory" tab
  3. Uncheck "Use new style save dialog (without file extension feature)"
1
  • 1
    Seems the default behavior has changed in a recent version. This gets it back to 'normal'. Apr 24, 2019 at 0:05
2

How do I set the default save extension back to the .txt default?

  1. Menu → "Settings" → "Preferences", or Alt+T then Enter

  2. Select "New Document" tab

  3. Set "Default Language" to Normal Text

    enter image description here

  4. Click "Close"

  5. Menu → "File" → "New", or Ctrl+N

  6. Menu → File → "Save As", or Ctrl+Alt+S

    enter image description here

  7. Click "Save"

  8. The file (in the above example) will be saved with the name new 1.txt

    enter image description here

    enter image description here

16
  • Default language is already put to "Normal Text"
    – Larper
    Dec 27, 2015 at 21:04
  • @Larper When you click Save it will save the file (in this case) as new 1.txt as per your request. Does this not meet your requirements? If not please edit your question and explain why this answer does not work for you.
    – DavidPostill
    Dec 27, 2015 at 22:23
  • I edited the question.
    – Larper
    Dec 28, 2015 at 9:31
  • @Larper Your question still does not make sense. I already told you the file gets saved as new 1.txt. You do not have to type .txt yourself.
    – DavidPostill
    Dec 28, 2015 at 9:34
  • 1
    @user598527 I'm running 7.2.2 and have never had the problem (on Windows 7). I'm updating to 7.4 right now.
    – DavidPostill
    May 17, 2017 at 20:03
1

Notepad 7.5.6 - mar 19 2018:

You have to choose between two Save File dialog bugs:

"Use new style dialog..." setting checked:
Default file extension is not used.

"Use new style dialog..." setting unchecked:
If you paste in the file name textbox a folder path without trailing "\", then click on Save button to set the folder path, Notepad considers the path last folder is a file name (and asks you to confirm for file replacement).

0

Reinstalling Notepad++ fixed the issue.

1
0

A fix that worked for windows 10: File explorer -> View -> checking the "File name extensions" fixed the issue for me.

Now when i use ctrl+alt+s, it automatically uses the file extension of the file i'm saving the copy of.

0

Version v8.1.2 (August 2021) was not saving the new documents as .txt even when the "Default Language" was normal text. To fix it, I found the following solution:

  • Settings → Preferences → New Document -> Change the "Default Language" to another extension like "Java".
  • Click Close.
  • Open the same settings page again and change it back to "None (Normal Text)"
  • Click Close again and it will save the default extension as txt this time

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.