1

My network consists of a modem which is connected to the router Buffalo WHR-HP-G54 (DD-WRT v24-sp2) where the signal is transmitted over the powerline adapters (D-Link DHP501-AV) to my Desktop PC (Ubuntu 14.04 LTS).

Ethernet over Power (EoP) problem

Layer-1 is working correctly. I successfully connected my PC to the router directly via RJ45 on the wired port. Pinging speed was 5x faster in connecting to the BUffalo router than to my modem. So the problem is in the EoP, and not probably in the router configuration.

Wiring of the house

The wired connection works with the previous modem but not with the current. There is only the house wiring now between my router and my PC, minimizing the effect of other cables. It may be the case that the power of the signal has different in the new modem, so interfering somehow the wired connection.

Router configurations

I have these Services in the router:

DHCP Server Enabled 
WRT-radauth Disabled 
WRT-rflow Disabled 
MAC-upd Disabled 
CIFS Automount Disabled 
Sputnik Agent Disabled

Wired

Settings about IP addresses managed by DHCP

% Automatic DHCP so not known exact handled IP range 
WAN IP 192.168.1.39 
LAN IP 192.168.2.1 
Start IP address 192.168.2.100 % so I think the range is ***.1 - ***.100

Advanced routing > Operating mode > Gateway % I am not sure about this: other options Router, OLSR router, RIP2 router, BGP
Port setup: WAN assignment vlan1 where everything *default* and not unbridged

I can detect the network in my Ubuntu 14.01 but the system cannot establish internet connection in the wired connection. In Buffalo's wireless connection, the internet connection can then again be reached but not in the wired. I do not understand this.

ping google.com gives ping: sendmsg: Network is unreachable in the wired connection. traceroute google.com gives nothing in the wired connection.

My wired connection has worked always before through the powerline adapter. We changed the modem some months ago which caused now the first problem. It may be the reason but I do not understand why.

cat /etc/resolv.conf gives in the Desktop PC with Ubuntu 14.04 LTS:

# Dynamic resolv.conf(5) file for glibc resolve(3) generated by resolvconf(8)
#     DO NOT EDIT THIS FILE BY HAND - - YOUR CHANGES WILL BE OVERWRITTEN

Wireless

I have only basic settings in wireless connection:

enter image description here

I have not changed anything such that the wireless would be connected to a different subnet so it should not be the case.


Why you cannot reach the internet connection in the wired network of Powerline adapters?

  • Need more info. What is your routers ip? What range of addresses is being handed out by DHCP? Is your wireless and wired network on the same subnet? Is your wireless VLANed to a different subnet? Does your pc get an IP address within the range of addresses you would expect a machine requesting an address via DHCP to get? What are you using as a DNS server? When you try to ping Google.com from Ubuntu, what error message is displayed in the terminal? Same question, but replace ping with trace route. Has your wired connection always worked or has it always had issues? Any changes? – Richie086 Dec 28 '15 at 7:31
  • I would assume someone with 1.5k rep would have included more relevant info with the question you have asked btw. You are far from being a noob here, masi. Please edit your question and include answers to the questions I have posed and hopefully we will be able to get you back up and running. – Richie086 Dec 28 '15 at 7:35
  • 4
    Step 1 is always check that layer-1 is working correctly. Did you try plugging something directly into the router on the wired port? If that works, then you know the problem is in the EoP, but if it doesn't work, the problem is in the router configuration. – Ron Maupin Dec 28 '15 at 8:01
  • 2
    @Masi Whats the local IP of the router? Does it match the EoP master? This is a common problem as they powerline adapters have fixed addresses. – Linef4ult Dec 28 '15 at 20:46
  • 1
    @Linef4ult Problem solved! Thank you for your answer! I changed one of the powerline adapters to be absolutely identical with the other one. The wired network works now. Please, make your comment an answer if you want I accept it. – Léo Léopold Hertz 준영 Dec 29 '15 at 7:50
2

Answer derived from comments:

EoP adapters usually have fixed IP addresses that can conflict with the router (and thus default gateway) causing problematic behavior. Changing your IP scheme to accommodate them will resolve this.

EG: TP Link often use 192.168.1.1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.