1

I'm trying to figure out how to get a chrome desktop app (Kiosk) to launch at startup. I've gone to system preferences > accounts > login items and added Kiosk (User > Applications > Chrome Apps > Kiosk) but it won't launch.

Any idea how to get these to launch properly at startup on mac osx?

I do have an automator application running at startup which executes a few node.js commands from a bash script, so maybe I could do it that way, but I'm not sure how.

If I go to the application icon and get info, I can see it says:

Default afhcomalholahplbjhnmahkoekoijban.app under name and extension, and its location is /Users/mikeheavers/Applications/Chrome Apps.localized but if I attempt to run:

open -a Default /Users/mikeheavers/Applications/Chrome\ Apps.localized/afhcomalholahplbjhnmahkoekoijban.app

from terminal it says that the file doesn't exist

0

I figured this out. It was a bit confusing so I'm posting the method I found here in case it's helpful to anyone.

  • open automator
  • got to file > new and select application
  • from the library, choose Run Shell Script and drag it to the window
  • In the run shell script dialog, enter the following:

(/Applications/Google\ Chrome.app/Contents/MacOS/Google\ Chrome --profile-directory=Default --app-id=afhcomalholahplbjhnmahkoekoijban) & This launches the chrome kiosk app - you will need to get the app id for your specific chrome app by going to the application icon (located in [user]/Applications/Chrome Apps/), right clicking, and going to get info. The id will be listed after Default in Name & Extension.

  • save the file somewhere, and then go to preferences > users and groups
  • choose your user account, and go to login items
  • click the + icon, and add the automator application you just created.
  • restart, and your chrome app should launch as well.
-1

Default is part of the file name; you should be using the path /Users/mikeheavers/Applications/Chrome\ Apps.localized/Default\ afhcomalholahplbjhnmahkoekoijban.app

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.