1

A few hours ago I started my PC and plugged in my Western Digital passport 2 TB(NTFS). When I tried to copy a new app to the software folder, there was only one folder. I check to see if there is any other folder with the same problem and I found out that the music folder has the same issue.

I checked the size of the drive it is 994 GB used. When I check the size of all files inside the drive it's 811 (the difference is about the amount of file that seems to be missing).

I searched for a file with everything search app and it found one on my PC and another one on the external drive. When I try to open it ** windows can't open the file "this is war.mp4" check the files name. The size of the file on the external drive is not showing.

I thought it was a virus so I scanned the drive with Kaspersky AV in full scan mode(twice) no virus found.

i tried to reveal the files with command prompt( with administration) like this:

attrib -s -h -r /s /d *.

still no luck

I restarted my PC and booted up with Kali Sana. The only difference was that Kali shows the software folder as empty while Windows show only one folder in it. The first os I used is windows 10 pro.

  • Run chkdsk /f on all of your drives, especially the external drive. – Tobias Knauss Dec 30 '15 at 8:39
  • it worked.i ran the command on all drives(at the end on external drive)and now everything is back. – vaas montenegro Dec 30 '15 at 10:18
  • can you post this as an answer and explain what the command does ? – vaas montenegro Dec 30 '15 at 10:19
  • Done as you requested. – Tobias Knauss Dec 30 '15 at 19:55
1

Run chkdsk /f on all of your drives, especially the external drive.
The purpose of this action: chkdsk means check disk. It checks the file system of the specified disk (and repairs it, if /f is used).

https://en.m.wikipedia.org/wiki/CHKDSK

Due to the thousands and millions of disk operations, something may go wrong eventually. Thus you should run chkdsk from time to time, especiall when you encounter disk failures like you mentioned.

-1

I am scanning old family photos and am keeping multiple backups of thousands of files onto a 2 TB Seagate external drive.

At the point where I had 240 GB of scanned files (specifically: 220,000 files, 12,100 folders) on the drive, I connected this external drive to an older Win 10 desktop (to which this drive hadn't recently been connected). Using Windows Explorer (only a few seconds after connecting the external drive) I saw some directories but when I quickly tried to drill down to the lower folders, the drive just "froze" (while in Windows Explorer)...and I saw the message that Windows Explorer was no longer responding.

At this point I thought the drive had been corrupted...which was not the case. After some investigative work, my fix was to just reboot the PC and leave the external drive connected to the PC for about 5+ minutes after which I WAS able to access all of the files.

Is it possible that your problem was that you had lots of files and didn't wait long enough before trying to access those files?

  • 1
    This is a very long way round to suggest an answer – Daniel K May 28 at 20:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.