0

Situation: Altogether, we have 5 computers: Desktop1, Desktop2, Surface Pro 4, Laptop1 and Laptop2.

  1. Up until today, all 5 machines (Windows 10 x64 with latest updates) had been connected to a Homegroup started by user XXX on XXX-PC. XXX is a local user on Desktop1 which until yesterday had been named XXX-PC.
  2. Today, in hope that I might solve some hiccups with the Homegroup, I made all the computers leave the homegroup and changed XXX to a MS account on Desktop1. Please note that now Desktop1 and Laptop1 are logged in by the same MS account whereas Desktop 2, Surface, and Laptop2 are logged in by another MS account.
  3. Please note also that Laptop2 is at my office so there it is not connected to another homegroup neither has it been disconnected to the Homegroup described in 1.
  4. I renamed Desktop1 so it is now no longer XXX-PC.
  5. So now, I expect from any machine among Desktop1, Desktop2, Surface, and Laptop1, I should have an option to create a new homegroup and have the three join that.
  6. However, here is what I am observing:

Desktop1: "You've been invited to join a homegroup." Recall that this is originally XXX-PC.

Desktop2: "You've been invited to join a homegroup."

Laptop1: "XXX on XXX-PC has created a homegroup on the network."

Surface: "XXX on XXX-PC has created a homegroup on the network."

So for each of these 4 computers, there is an option to Join but no option to Create a homegroup. Laptop2's behavior is unobserved because it has not been part of the process described in 2.

Question: what is going on and how do I fix things to attain the goal described in 5 above? Thank you for your time.

Edit: I ran the Homegroup troubleshooter on Desktop1 and Desktop2. "Troubleshooter couldn't identify the problem" in both cases but now both Desktop1 and Desktop2 also read

"XXX on XXX-PC has created a homegroup on the network."

Edit 2: I have reset Desktop1. Desktop2, Laptop1 and Surface still sees a homegroup set up by "XXX on XXX-PC". Even the freshly reset Desktop 1 (aka the former XXX-PC) is still seeing a homegroup set up by "XXX on XXX-PC."

0

I took an extreme measure that nonetheless solved the issue: the Surface Pro 4 was reset and from that point on, the ghost homegroup by "XXX on XXX-PC" was no longer visible. As far as homegroup-ing goes, things are now normal.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.