2

Essentially, I was trying to work on a HFS+ disk I have (under W10), so installed Paragon HFS+ to be able to access it. However, unfortunately, I rebooted my computer after installation and got a BSOD -- "Inaccessible boot device." I have since been completely unable to get it to boot into this Windows installation.

I've tried literally everything:

  • Booting into recovery to try to have it automatically fix it (of course, it didn't work.)

  • Disabling Paragon HFS+ from the registry

  • Removing Paragon HFS's registry keys as suggested by one of the few other people on the internet who has had this problem (to no effect)

  • Recreating my EFI partition

  • A variety of different SATA plugs on my motherboard

  • Booting into another OS (works! but not the solution)

  • Mucking about with bootrec / etc. in the recovery command line from the installation media

  • Changing the boot order of my drives (and unplugging all but the Windows 10 one)

  • Ensuring with diskpart that the drives are assigned the correct lettering

... with no luck. I've checked the files on the drive, and everything is intact. I've recreated the EFI partition and the MBR, and both methods of booting get to the loading screen, spin for a bit, then give the same BSOD.

I cannot feasibly reinstall this drive's copy of Windows at the moment, so must somehow get this installation working again.

Is there any way to manually remove Paragon HFS+ from the installation via another installation of Windows on a different drive? I've tried WMIC but that doesn't seem to work, or even theoretically allow me to target a different drive.

Or, conversely, is Paragon even the problem? According to https://www.reddit.com/r/techsupport/comments/36ies0/inaccessible_boot_device_after_uninstalling_hfs/ , it's been known to cause this issue...

Is there any way I can salvage this? The installation is there, it gets to the loading screen, the drive is fine, all of the necessary files are there, the program I thought could be the issue is functionally disabled... I truly have no clue what the issue could be.

System:

  • AMD FX8320

  • Gigabyte GA-970A-D3

  • 12GB Ram (tested functional -- not the issue)

  • Gigabyte GTX 760

  • 3 drives:

    • 120gb solid-state drive with the broken Windows 10 install, and an EFI partition to boot it from.

    • 2TB drive with data

    • 1TB drive with data and a OSX Yosemite installation

0

Here is what worked for me, strangely enough, and after hours and hours struggling to recreate UEFI boot structure.

Symptoms:

I was getting INACCESSIBLE BOOT DEVICE, as well as 0xc000000e errors, and sometimes also 0xc0000001 errors ("after multiple tries the OS on your PC failed to start ...").

Solution:

  • If you can get to the Windows recovery screen, click Advanced and then the option for Startup Settings.
  • Select Safe Mode.
  • Restart
  • Let Windows boot into safe mode.
  • Restart again.
  • Let computer load normally.

I am not sure what Safe Mode fixes, but suspect at the end of this ordeal that it was not a BCD boot problem but was actually a corrupt driver and (somehow) booting into Safe Mode fixed the issue.

Post-script

In restoring my BIOS settings to their original state (as I had changed them quite a few times in getting my computer working), I found that in changing ACHI back to ENABLED (it was then set to DISABLED), I again had another INACCESSIBLE BOOT DEVICE crash.

I booted to safe mode and checked Windows drivers. The drivers for my hard drive controllers and hard disk drives had converted to IDE. In safe mode, the ACHI drivers were loaded. In normal Windows loading, the IDE were loading, Hence, when changing my BIOS to ACHI, I would get a crash in normal loading situations.

I booted to safe mode, removed all IDE drivers by CONTROL PANEL -> DEVICE MANAGER -> VIEW -> SHOW HIDDEN DEVICES. Under DISK DRIVES and IDE ATA/ATAPI CONTROLLERS I removed all instances of IDE drivers. (They were not in use, because I was in safe mode, and the ACHI drivers were being used.)

I then rebooted, and ensured that ACHI mode was enabled, and everything has gone well since then.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.