1

I have an NVIDIA GPU and latest drivers installed. However, when I run dxdiag and go to the Display tab, it says my device name is Intel HD Graphics 3000. I should be using the NVIDIA card though.

However, I read somewhere that I can set the NVIDIA to take over when I play games (Dota 2). How can I check this? Could that be why the Intel card is listed?

Update: that other question's answer didn't fix my problem. I went into the nvidia control panel and changed the global setting to apply the nvidia processor, but when I run dxdiag I still see the Intel Graphics card listed.

  • You have to change the setting in the BIOS. – whs Dec 31 '15 at 0:06
  • 3
    Seems like a duplicate of superuser.com/q/525041/29943 – Ben Voigt Dec 31 '15 at 0:43
  • 1
    it is a duplicate. but to clarify there is no change in bios required. nvidia control center will detect your game and run it with nvidia gpu. even if it doesn't you can easily define your own application profile from nvidia control center interface (or choose run this with graphics adapter.. option from right click menu) – conquistador Dec 31 '15 at 7:38
  • @BenVoigt unfortunately, that didn't seem to change what dxdiag thinks. It still says I'm using the intel card. – whatwhatwhat Dec 31 '15 at 22:53
  • @whatwhatwhat: Did you set (in Optimus configuration) dxdiag.exe as one of the applications that uses the dGPU? – Ben Voigt Jan 1 '16 at 1:59
0

Right click on the icon that launches the game and then click "run with graphics processor" then select Nvidia

  • By including some more information this would be a great improvement for this answer. – Seth Jan 20 '17 at 9:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.