I have this fancy new ubuntu server I just built assembled, and I'm trying to set up ssh from anywhere so I can keep it headless.

I've been able to set it up locally, and as long as I'm on the network, I can ssh in with ssh user@ipv6address and terminal away. I found the ipv6 address with ip -6 addr show and double check with curl icanhazip.com. I don't think it's the local address, because it doesn't start with fe80.

Now I'm trying to set it up so I can ssh in from anywhere and I'm running into a lot of problems. I've only ever set up remote ssh with IPv4, where your router has a public IP address, and you'll forward the public ip to the local address for port 22. Obviously, this isn't the way it works for IPv6. I'm very much a software guy, and I know very little about IPv6, so it's been a struggle to get this working.

From what it sounds like, I don't need to forward the ports or anything, as I believe my server's IPv6 address is already unique and public. However, I think that my Linksys router has a firewall or something and I can't figure out how to open port 22.

Probing the ports reveals all ports (including 22) are being "filtered". I'm assuming my linksys router has some setting that is blocking access on all ports, but I'm not sure which setting I have to change.

Specs:

  • Blackbox Ubuntu Server running 14.04 LTS (specs are probably irrelevant)
  • Linksys EA6700 running stock firmware v1.1.29.162351
    • accessed through the Linksys Smart Wifi interface. bleh.

Things I have tried and hoped would work but totally didn't:

  • add IPv6 Firewall Setting allowing port 22 to the public IPv6 address
  • disable IPv6 SPI firewall protection
  • disable IPv4 SPI firewall protection
  • disable Filter anonymous Internet requests
  • add Single Port Forwarding for port 22 to the local IPv4 address
  • add DMZ rule to point any IP address to destination IP

Here are some screens of my router's interface, displaying the things I've tried:

enter image description here

I don't really know what else to do from here. Flashing an open source router firmware is not an option for me, unfortunately. I guess I could disable IPv6, but that's not really a scalable solution.

I feel like it should not be that hard to open a single port on my router, and I'm not sure how to get this working. Any help y'all could provide would be immensely appreciated! Let me know if you need more information.

migrated from serverfault.com Dec 31 '15 at 3:02

This question came from our site for system and network administrators.

  • 3
    Is your IP address in the 2000::/3 range? When trying to access it from outside, does the outside host have a public IPv6 address and ISP IPv6 support? – Ron Maupin Dec 31 '15 at 5:58

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.