4

My university provides native IPv6 support in campus network, and I want to let devices (running Linux) in my TL-WR720N router's LAN have IPv6 access.

After many trials, I can make LAN devices able to get Global IPv6 addresses. But when I ping6 some websites, it always says "Network is unreachable", whereas these websites all responded normally when I ping6 them on the router.

Here are my config files:

root@OpenWrt:~# cat /etc/config/network 

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdc8:3a9f:1840::/48'

config interface 'lan'
        option ifname 'eth1'
        option force_link '1'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6hint '1234'
        option ip6assign '48'

config interface 'wan'
        option ifname 'eth0'
        option proto 'dhcp'

config interface 'wan6'
        option ifname 'eth0'
        option proto 'dhcpv6'

root@OpenWrt:~# cat /etc/config/dhcp 

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.auto'
        option localservice '1'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv6 'server'
        option ra_management '2'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'

root@OpenWrt:~# 

I have relatively poor knowledge about IPv6 network and not familiar with some stuff such as Router Advertisement, NDP, IPv6 assignment length/hint, etc. It's really appreciated if someone can help.

  • You said that when you ping some websites it says the network is unreachable. Could you provide us with a traceroute to both working websites and non-working websites. Can you browse to the "non-working" websites on their ipv6 addresses? – David Dec 31 '15 at 15:32
  • @David sorry for the ambiguity. In fact, when I ping6 these websites on the router, all of them responded normally. But when I ping6 them on LAN devices, all resulted network unreachable. – user303446 Dec 31 '15 at 15:57
1

You need to request an IPv6 prefix from your upstream provider for the machines on the LAN side of your router to use; this is called DHCPv6 prefix delegation.

config interface 'wan6'
        option ifname 'eth0'
        option proto 'dhcpv6'
        option reqaddress 'force'
        option reqprefix '56'

Of course, this will work if and only if the upstream provider actually provides routed prefixes. In a campus dorm, this may or may not be the case. Contact your university's IT services and ask about this if you don't get a routed prefix after doing this.

0

Im just going to leave this here, it might help you or another. I deleted my wan6 interface when i was first trying out openwrt not knowing what it was for and figuring i didnt need it.

After recreating it it still would not work. Im using ppoe that is different from OP.

The trick which was different to all the guides around was that i needed to set the wan6 interface name to "pppoe-wan" rather than "@wan" or "eth0.2"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.