I have a custom-built computer based on an ASRock motherboard, and both Linux Mint 17.2 and Windows 10 installed.

When I shut down the computer, from either OS, the USB devices remain on. I'd rather they turned off when the computer is off (as they're useless anyway) so I found that the relevant UEFI setting is named "Deep sleep". I switched that setting from "Disabled" to "Enabled on S5" (S5 is the computer's shut down state).

The setting did what I expected, but it had an unintended side effect: With it on both Mint and Windows fail to shut down the computer correctly, and instead seem to "freeze" at the last moment before it would actually shut down. I can only turn it off from that state by holding down the power button.

Why does the above happen? Is there a way to keep the Deep Sleep setting on but make the computer shut down when the OS tells it to?

Describing what happens in more detail:

  • On Mint, the screen just shows the Mint logo that appears normally when the OS is starting or shutting down. If I disable splash, the last output from the kernel is "reboot: shutting down".
  • On Windows, the screen goes off entirely: The monitor itself displays a "no signal" message.
  • In both cases, everything in the computer seems to still be powered, as the cooling fans still work.
  • S5 is a "soft off" describe by Microsoft as "The system appears to be off. This state is comprised of a full shutdown and boot cycle.". Are you sure the power supply supports this power state? Windows 10 by default uses hybrid shutdown. "Starting in Windows 8, fast startup is the default transition when a system shutdown is requested. A full shutdown (S5) occurs when a system restart is requested (or an application calls a shutdown API)." Your problem is normally caused by some hardware not respecting the power state (i.e. driver problem). – Ramhound Dec 31 '15 at 16:17
  • Windows' "fast startup" is turned off, to allow Mint to read the partition -and in any case wouldn't affect Mint's shutting down. I'll look into the power supply... – George T Dec 31 '15 at 16:21

This is a bios bug the s4 and s5 is broken. There exist a beta bios for asrock z97 anniversary that fixes it with number L2.16


last answer

  • 1
    can you provide more information on the BIOS patches (where to get them, how to apply them etc?) – Stese Mar 28 at 11:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.