2

I have a home folder on windows box at work.

//SERVER/SHARE/hq/USERNAME

username is what i want to mount. SHARE is the share. HQ is folder I don't have access to or SHARE directly it seems. I can mount SHARE but i can't see inside it.

When i try to mount i get permission denied, but I have the correct permissions, because I use the same ones to mount another share on the same server, but its only one folder deeper.

sudo mount --verbose //SERVER/SHARE/hq/USERNAME /home/USERNAME/mounts/home -t cifs -o uid=1000,gid=1000,credentials=/home/USERNAME/.creds,iocharset=utf8
domain=DOMAIN
mount.cifs kernel mount options: ip=10.252.56.36,unc=\\SEVER\SHARE,iocharset=utf8,uid=1000,gid=1000,user=USERNAME,,domain=DOMAIN,prefixpath=hq/USERNAME,pass=********
mount error(13): Permission denied
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

However when i mount this path with same options and creds it works:

//SERVER/common/HQ

the SERVER in both commands are the same.

The one i cant mount with "mount -t cifs" I can mount with gnome files (Nautilus) with no problem, but that's not any good to me, because i need to access those shares from cli remotely. I have a script that does this and it worked in fedora 21.

My guess is its the 2 folder deep problem. I tried mounting in fstab and playing with slashes with no luck. But reading documentation i see why it made no difference.

EDIT Also I can mount //SERVER/SHARE but i don't have any privileges there and i'd probably give up except that A: I know this worked before and B: Gnome Files can mount it just fine.

Thanks.

0

You must log in to answer this question.

Browse other questions tagged .