2

I'm trying to connect to a VPN using SSL Network Extender, and am getting Java is unavailable error.
This occurs in 32 bits Java on 32 bits Firefox in Windows 7 (64 bits).

Since both browser and Java are 32 bits, I'm in the woods as to the possible cause:
can you suggest what should I do to make Java work in Firefox?


Details:

  • Firefox: 43.0.1 C:\Program Files (x86)\Mozilla Firefox
  • Java: 7u45 (build 1.7.0_45-b18) http://java.sun.com/products/autodl/j2se
    C:\Program Files (x86)\Java\jre7\bin\javaw.exe

Error popup:

Java is unavailable error popup

Java:

java version java is enabled


Edit 1:

I uninstalled all Java versions and installed latest 32 and 64 bits Java - and verified that Java works. Still, am getting the same error popup.

Java versions installed:

java versions installed

Java verified:

Java verified

The error popup:

error popup


Edit 2:

Java verified:

Java verified

Java plugin is enabled:

Java plugin is enabled

plugin scanning is not disabled:

plugin scanning is not disabled

closed as too broad by JakeGould, DavidPostill Feb 10 '18 at 16:56

Please edit the question to limit it to a specific problem with enough detail to identify an adequate answer. Avoid asking multiple distinct questions at once. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • Any luck on this matter? I am experiencing the exact same symptoms... – Stav Jun 1 '16 at 20:36
  • I used chrome to solve the issue, @Stav. When I received your question, I tried FireFox again, and it works now. Note that my FireFox was upgraded since then to 46.0.1 – boardrider Jun 2 '16 at 15:42
  • Thanks for the reply. The docs from Checkpoint state Chrome is not supported due to it not enabling NPAPI plugins any more... I'm surprised you got it to work there. How did you manage to install the Java plugin? BTW, in Firefox 32-bit, are you still using Java 8 U66? I started getting problems after updating to the latest SE 8 U92. – Stav Jun 2 '16 at 19:36
-1

Test if your browser has Java installed using the official Java website: https://www.java.com/en/download/installed.jsp

Moreover, maybe the website you're trying to access needs Java enabled upfront in order to verify Java installation? (Java plugins not run by default in Firefox)

  • 1
    OP mentioned he reinstalled Java and verification was successful. – pun Jan 1 '16 at 14:40
  • Per your second suggestion, see Edit 2 – boardrider Jan 1 '16 at 15:23
  • Oops, overlooked that. My bad! – TomTasche Jan 1 '16 at 15:27
-2

I had this issue even after uninstalling all my existing Java installations and re installing the latest official Java but I was still getting the Java unavailable message. So this fixed it for me.

1) restart your firefox and make sure the firefox process is really dead before you start it again 2) When you get to the popup that says Java unavailable try Ctrl+F5 which will force a cache refresh. This fixed the issue for me

-2

What worked for me: On the Java Control Panel, General tab, Temporary Internet Files, Settings... I deleted the files and made sure the Installed applications and applets is also chosen. Worked like a charm after that. Also the Extender possibly needs Java 1.7 Hope that helps...

Not the answer you're looking for? Browse other questions tagged or ask your own question.