I have a new ASUS Zenbook UX305. OS: Windows 10 Home

I've figured out that my laptop wakes up from sleep during the night, so i reviewed the event viewer and found out that it happens about 3-4 times each night.

I searched the web, applying the following solutions:

  • Disabled Advanced Power Settings -> Sleep -> "Allow wake timers"
  • powercfg -lastwake shows the wake up trigger was the power button.
  • In the device manager, I disabled the "allow to wake up" feature of the mouse, "wake on lan" and "wake on pattern match" of the WAN adapter.
  • powercfg -devicequery wake_armed shows NONE.

And it still wakes up like a crying baby.


I found out that the laptop wakes up exactly 3 hours after I put it to sleep, so I googled again using this new piece of data.

Paradoxically, my laptop (and probably many other laptops) wakes up in order to hibernate, but for some reason the hibernation fails - resulting with the laptop "staying awake".


Right-click on the Start button and select "Power Options".

"Change when the computer sleeps" > "Change advanced power settings"

"Sleep" > "Hibernate after"

  • On battery: Never
  • Plugged in: Never

enter image description here

Source: eightforums.com

  • This is a workaround (not actually a solution). If you keep the PC sleeping for a prolonged time, it will drain the battery. – sancho.s Jul 13 '16 at 5:51

This happens due to windows 10 crappy built-in settings to install updates. Lots of users are experiencing this weird problem.

To fix this follow the method below.

  1. Search Task Scheduler in the Windows 10 task bar.
  2. Browse to the following location path from the left menu.

Task Scheduler Library → Microsoft → Windows → UpdateOrchestrator

Now, double click on Reboot as shown in the pic below. Click on Conditions tab and then uncheck the option which says Wake the computer to run this task.

Source: http://merabheja.com/prevent-windows-10-rebooting-in-sleep-mode-to-install-update/

  • This option is already unchecked. – ozking Jan 5 '16 at 21:45
  • This setting tells Windows when to reboot for updates. Not when to wake up. – Adrian W Oct 18 '18 at 6:03

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.