3

I installed xorg, I can successfully startx and I installed i3 on arch linux. How can can I change, or more specifically; increase the size, in the default terminal in i3? From the i3wm documentation it states I can do the following: font pango:Terminus 11px but that results in a font: command not found error. I hope someone can guide me in the right direction.

** EDIT **

I was able to change the font and font size but the font is still small. I am on a 13" laptop with a high-res screen. Also, arch linux is installed on a virtualbox. Guest additions were installed and work. I created ~/.Xresources file with the following

xterm*faceName: dina-font
xterm*fontSize: 20

I also edited my ~/.xinitrc file with

xrdb -load /home/username/.Xresources & 
exec i3

When I start X, i3 load with the settings from ~/.Xresources: dina-font (Monospace) and size 20. However it is still small.

When I increase the size using the xterm*fontSize setting or Ctrl + Right click, only the cursor block gets bigger but the actual font does not. Perhaps this is a screen resolution at this point?

2
  • You might be running xterm, but there is not enough information to see what the actual default terminal is. The pango setting won't work for xterm. Each of the possible terminal emulators will have a different way to specify the font. – Thomas Dickey Jan 2 '16 at 18:51
  • I hope you have changed username to your actual username. – cee Jan 3 '16 at 7:27
1

It's not fully clear if you want to change the font in your terminal (are you using xterm?) or in your vconsole before issuing startx command.

To change the font size in xterm:

xterm*faceSize: 23
1

If you haven't changed anything with i3wm then you're probably launching i3-sensible-terminal. Check your ~/.i3/config and see what you have entered for the line $mod+return that will tell you which terminal you're launching and if you want to you can change it there to something you may already understand (i.e. xterm). this terminal then pulls up a shell.

The shell you're using is going to affect how you can change font size/style. Type ps and see which shell you're running. After that you can google around how to set the font settings for the specific shell.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.