26

I have HP's Bang & Olufsen stuff factory installed. This appears to be built on top of Realtek HD Audio manager, yet the sound manager is still B&O. I want to disable the realtek notification every time I un/plug anything from/into audio jack. I can't find any jack detection options on my comp.

Disabling the notification in Windows settings disables until a restart of the computer. I couldn't find any way to change windows notifications besides the Windows 10 settings app which clearly has some issue that's causing this problem.

I have this HP laptop running Windows 10 Home Version 1511 Build 10586.29. I'd prefer not having to switch audio drivers if possible.

Any ideas how to permanently disable this notification?

(To be clear, I only want to disable this one notification and no others. I know that I can disable all Windows notifications but I do not want to do so).

6 Answers 6

43

Go to Settings > System > Notifications and actions and under Get notifications from these senders, scroll down and turn off Realtek HD Audio Manager

1
  • Thanks! I see that MS added this functionality in one of the latest updates; when I posted the question this option did not exist. Will mark this as the answer for posterity.
    – joepin
    Mar 23, 2017 at 0:36
13

I found a solution here that worked for me. Basically:

  1. Open the Realtek HD Audio Manager through the Control Panel.
  2. Click on the lowercase "i" on the bottom right of the Audio Manager window that pops us (just above the OK button).
  3. Uncheck "Display icon in notification area".
  4. Click OK twice to exit the Audio Manager.
1
  • Thanks for the answer! Unfortunately, I don't have access to the Realtek Audio Manager, since HP's B&O stuff replaces it. So this would in theory work but not on my computer. I have long since given up on this issue, and just suffer in peace with the notification.
    – joepin
    Aug 9, 2016 at 0:58
3

For those with no success with the previous suggestions: In my case (Windows 10 Version 1803 build 17134.254), what finally did work was to go to Task Manager > Startup tab, and right-click on the Realtek HD Audio Manager and select Disable.

Screenshot

2

For many people, the Realtek Manager doesn't appear in the control panel and you must find rtkngui64.exe in your realtek install folder to launch it.

By default, this is in C:\Program Files\Realtek\Audio\HDA

Once open, just like the other answers, go into settings and uncheck the box to disable the popup.

0

This worked for me: Remove the Microsoft driver completely and download it from the producer Realtek. That doenst have the notification posibility

2
  • Could you explain remove Microsoft Driver completely ?
    – clhy
    Jan 4, 2016 at 3:27
  • Confirm checkmark 'remove' in the process
    – Dirk Zaal
    Feb 13, 2016 at 7:48
0

I had the same issue, I attached the link below basically go to the start > realtex audio console > device advance setting > enable jack detection when device is plugged in > turn it off.

https://techwiser.com/how-to-disable-annoying-headphone-jack-plugged-in-popup-on-any-asus-laptop/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.