I am trying to create a keyboard shortcut to raise an application that is running in the system tray (keepassx).

I have tried xdotool but it does not work. xdotool finds the windows that match the app name but activatewindow gives an error (XGetWindowProperty[_NET_WM_DESKTOP] failed (code=1)) my guess is that the application does not have a window to activate.

I also tried wmctrl with similar results, in this case no window is found.

Any ideas of what I can do?

I am running Lubuntu 14.04 LTS - LXDE / Openbox

  • I am having the exact same issue, did you ever find a way to make it work? Nov 3, 2016 at 0:14

2 Answers 2


My experience with kde:

I assigned shortcut to my tray icon application. To raise it from tray by command I use: xdotool key "my shortcut"


I had the same error. Tried both wmctrl and xdotool but they don't seem to work with a window hidden in system tray.

I solved it with simple bash -c "pkill keepassx && keepassx". For this to work Start minimized need to be unchecked. Used with KeePassX 0.4.3 .

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.