0

I use Wifi at home and my Virtualbox network mode is bridge adapter + promiscuous

centos 6 network information is

enter image description here enter image description here enter image description here

Winows10 can ping guest centos6

enter image description here

and I can use secureCRT to conncet to centos6 enter image description here

but centos 6 cannot ping windows10 or other webstie

centos6:192.168.56.102

win10: 192.168.1.105

enter image description here

what should I do ? thank you very much

2
  • Slightly off-topic remark: why are you logging in as root?
    – oldmud0
    Jan 3 '16 at 3:54
  • @oldmud0 because root makes me feel powerful like a Spiderman :)
    – LawrenceLi
    Jan 3 '16 at 6:31
1

One or both of these two things are probably blocking you.

  1. The windows firewall has three Classifications, Domain, Private, and Public. By default ICMP Type=Echo is disabled on the windows firewall for all classifications.

  2. Sometimes the network, which is the software side of the hardware interface doesn't get properly assigned to a firewall classification. Out bound communication will still work, but incoming rules will work inconsistently.

To solve the first:

Open the Windows Firewall from Control Panel or wf.msc from the search box and right-click to run as Administrator.

Under Inbound Rules, enable the rules your need:

   File and Printer Sharing (Echo Request - ICMPv4-In)
   File and Printer Sharing (Echo Request - ICMPv6-In)

You may want to change the properties on each rule (right click -> properties) Advanced Tab, to limit the scope the rule apples to by removing Public.

To solve the second:

Sometimes windows doesn't properly assign the network connection to the proper network classification automatically.

The last comment from Itai Shaham on this locked TechNet thread will probably fix the issue for you.

  1. Open gpedit.msc
  2. Goto Computer Configuration > Windows Settings > Security Settings > Network List Manager Policies
  3. Find the Network Name of your network connection on the right side of the window (may be just Network) and double-click it to open its Network Properties dialog
  4. Goto the Network Location tab and change the “Location Type” to "Private"

Security issue: If this is NOT a system that will see multiple networks change, e.g. something with wireless or a laptop and you have a private network showing as Unidentified Network, step 3b would be to move all current and future Unidentified Networks into the classification of your choice.

Unidentified Network appears when windows can't find the defined gateway on that interface.

Comment: I found this unanswered question while looking for a similar issue. Once I fixed it, this was how. My problem was with ping and Windows RDP and not allowing a connection from win7 to Win10 with NLA security enabled. The ping still didn't work between networks but did work in the local network until I did the second step.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.