1

I installed Windows 10 on one of my PCs when the machine was offline. So Windows created a local account. Later when that device went online, I linked it with my Microsoft account, but now that account doesn't have the same users-folder name as it has on my other PCs.

On the machines where I was online during the installation of Windows 10, the user-folder is "C:\users\email", and I want to have the same name on this new machine, where the folder-name now is C:\users\Martin.

What is the most simple solution to restore the default folder-name (C:\users\email) that Windows 10 automatically creates when you don't create a local account during installation, without installing everything again?

Thanks in advance!

Edit: this is not about how to just rename the account. I want to know how to make Windows create the default name of the user-folder, like it would do if I'd used my Microsoft account during the installation.

0

the simplest answer since the windows 10 machine in question is now online is to unlink the local account from your microsoft account, create a new user with the microsoft account you want and then after copying the contents you want over to the newly created account with the appropriate named user folder that you want and then disable or even delete what is now the old local account.

mc

  • I don't think I understand. The only account is the Microsoft account. It just doesn't have the default name put as the users-folder-name. – MartinRJ Jan 4 '16 at 10:05
  • ...also the account is named "Martin" and not like my MS email-address, as expected. When I just copy-paste the contents of the users-folder, there is a danger that the permissions of some of the files will be messed up afterwards. Also I don't know how to unlink the local account from my Microsoft account. – MartinRJ Jan 4 '16 at 10:23
  • *Found out how to unlink the local account. I did it similar to the way you've described, but it's not very elegant, I'd still like to find an answer to the question of how to do this without having to manually create another 'dummy'-account. – MartinRJ Jan 4 '16 at 10:33
  • Just like I had feared, now I cannot access the account anymore, after copying the files from C:\users to the new account, due to missing permissions. – MartinRJ Jan 4 '16 at 10:45
  • I can not even open Explorer.exe - I just get an error message regarding missing permissions. All symbols from the taskbar are missing. – MartinRJ Jan 4 '16 at 10:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.