Objective: Get scanning to work with a Hewlett Packard MFP M276nw, connected via USB to a Windows 7 x64 system.

What I did, step by step:

  1. Uninstall printer driver from Device Manager.

  2. Uninstall HP software from Control Panel\Programs\Programs and Features.

  3. Manually run HP driver uninstaller:

  4. Unplug the device from USB.

  5. As Administrator, start the latest printer/scanner setup tool, downloaded from the HP web site: HP LaserJet Pro 200 Color M276 PCL6 Print Scan Driver with Installer - LJ-Pro-200-color-MFP-M276-driver-installer-15188.exe

  6. Plug in USB when asked by the setup tool. Now, something possibly goes wrong already: Windows 7 picks up driver installation in parallel.

    Screenshot showing setup tool and Windows' driver installer

  7. Wait until the setup tool finishes, unfortunately with an error message: "An install operation took too long to execute. This is a fatal error preventing product use. Please restart your computer, and run this installer again. If the problem persists, please check the product support web site for your product."

    Screenshot showing setup tool with error message

The log file of the HP setup tool shows details about the error message, but I don't know what to look for. The Windows driver installation log file C:\Windows\inf\setupapi.dev.log looks fine, no error messages.

What can I try to solve the problem?

See also my post in the HP support forums.


3 Answers 3


Just followed the procedure again, but with an additional step 1a: Uninstall printer from Control Panel\Hardware and Sound\Devices and Printers

Prior to that, I ran the HP Print and Scan Doctor, but that only showed which devices are installed. I doubt that it fixed anything.

Anyhow, this time installation worked, although again I had to wait a long time for the setup tool to finish. Possibly it's a timing issue.

No TWAIN interface seems to have been installed for the MFP. Possibly that requires the full setup with the HP scan software. However, I can now scan with VueScan, which did not work before.

  • I'd suggest using NAPS 2 for your scanning, but that's just an idea. If your software works then everything's fine I guess.
    – Simmen
    Aug 11, 2016 at 20:20

Go into the printers settings (in the printer itself) and turn off "HP Smart Install".

Settings -> Service -> HP Smart Install -> Off

Then try to install it again, and it should work.

I've been fixing this at work a few times now.

  • This happens most time when I Install HP's printers, it stucks at 99% at some time and then it shows error...
  • I fix this by manually install printer driver from Device Manager.
  • First you need to extract printer driver and copy that location where you extract it.
  • Go to Device Manager/Printers, right click Update Driver, then click Browse, locate extracted driver (You can pasle already copied link) and install it manually.
  • Very much THIS! Thanks Sir, unbelievable how unintelligent (and unhelpful) this "Smart Install" is.... WTF... Apr 11, 2020 at 4:15

Not the answer you're looking for? Browse other questions tagged or ask your own question.