2

I have this weird problem in my laptops internet connection. I use this laptop for my day to day work + company work. With my company internet connection there are no issues, internet works fine (goes through a proxy).

But when i use my laptop with any other connection pages stops loading. Gives me err_connection_refused error. But there's nothing wrong with the internet connection. It works fine, i tried pinging too, and it works. And i tried loading pages with IE and Firefox, same thing. Did not load pages.

However, i noticed that only HTTP sites are not being loaded by the browsers. HTTPS sites work fine such as Google(Every google service works properly). I did everything in the answers which google search provided me with this case. But i didn't find an exact case like this.

This started with a browser hijacker called Snapdo. Somehow this thing got installed, and i removed this thing entirely from the machine using IObit Uninstaller, Ran malwarebites scans, ran AVG scans. Removed temp folders and removed almost every trace i could find. And reseted browsers to their original conditions, reinstalled them too. Nothing happens...

PS : sometimes it works for a minute or two and just stops working again. There are no malicious processors or services i could find either. Removed everything that looked malicious and untrusted. Can anyone help me on this?

  • Obviously if you completely removed Snapdo the behavior you describe wouldn't exist. You must have missed something. – Ramhound Jan 4 '16 at 13:10
  • @Ramhound i guess you are right... I found some program data related to Snapdo called as "Vaiafineco" in Program Data folder. But i had deleted that folder previously. Seems some other program writes the stuff again somehow. I deleted and did another registry check up. And it started working. – k9yosh Jan 5 '16 at 4:42
0

Here are a couple things you should check:

If you have Administrator rights, try using Google Chrome or Mozilla Firefox to see if those work. If so, you may need to check through the Addons and Programs in Internet Explorer to make sure nothing is leftover in there. After performing the above steps, restart your computer first. This should clear out the DNS cache and get DNS server settings again.

Also, you can try visiting the website "104.16.125.192". This is an IP address of superuser.com. You will reach a Cloudflare page that says direct IP access isn't allowed if it works correctly. This will test to see whether the problem is DNS related.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.