4

For some time on my Windows 10 desktop PC, neither does the "Microsoft XPS Document Writer" nor the "Microsoft Print To PDF" virtual print drivers seem to work.

Whenever I try to print a document using either one, it prompts a file dialog for me to pick a filename and location, and when I click OK to print, it does nothing. The dialog window disappear, no error is shown, and nothing else happens. When I look at the directory where the file was supposed to be created, there is nothing, not even a zero-byte file. The directory where I save the file does not have any special characters in it (no comma), and I have full admin access to it. The Windows Event Viewer doesn't show any error either.

If I try to print a test page using the Printer properties panel of each virtual printer, it gives me an error saying "Test page failed to print." and proposes me to use the troubleshooter (which I did and it found nothing).

I have also tried to uninstall and reinstall both printers (using the "Turn Windows features on or off" panel), with a reboot in between, but that didn't fix the issue.

I have a network printer installed which is working fine. User access Control is also disabled (slider all the way down) and my account type is administrator.

This used to work before (although I can't pinpoint when exactly as I don't use it often enough). I suspect it was caused by a Windows update, but since Windows 10 updates are mandatory and can't easily be excluded, even if I uninstall the last updates in the Installed Updates list, they come back the minute I reboot, and I can't hide them like I could in Windows 7.

This is a fresh install of Windows 10 Pro, and not an upgrade.

I have spent quite a while searching Google for this issue but the only cases I found were about commas in the filename or path and was only affecting printing from Edge, which is not my case. Any help would be appreciated. Thanks !

18
  • do you have ALL windows updates installed? there were some printing issues in early realease of windows 10. – juFo Jan 5 '16 at 8:13
  • Yes, all updates are installed. – Yanick Girouard Jan 5 '16 at 12:06
  • and the November major upgrade? – juFo Jan 5 '16 at 14:11
  • Yes, as far as I know you can't opt-out of Windows updates in Windows 10. They are always enabled and there's not even the option of disabling them or excluding/hiding them. And I do hate that about it ! – Yanick Girouard Jan 5 '16 at 16:28
  • 2
    Quite a few odd ones arrive on this forum after each and every update of Windows 10. Most of them have no solution except waiting for Microsoft or downgrading to Windows 7. – harrymc Jan 11 '16 at 15:20
5
+100

When Microsoft CEO Satya Nadella has decided to cut 5,500 Microsoft employees, with Windows hit the hardest, much has changed in the Windows world. Nadella has cut a lot of testing engineers, adding the role of testing to that of product manager, and relying much more on the Windows Insider Program.

Unfortunately, that coincided with the release of Windows 10, an operating system that was rushed out much too soon and without enough testing, relying instead on a very rapid rhythm for updates to fix the expected problems, which did arrive soon after.

Unfortunately again, because of a lack of testing and quality assurance, the fixes that are now being rushed out tend also to cause problems in their turn.

It is with great sadness that I witness on this forum, after each and every major update of Windows 10, the arrival of new problems. Most of them have no solution except waiting for a fix from Microsoft or downgrading back to the very stable Windows 7.

So there are very few solutions that I can offer to your problem :

  1. Run sfc /scannow to verify that, for Windows, its actual broken state is "normal".

  2. Check the Event Viewer for error messages relating to your problem.

  3. Report the bug to Microsoft using the "Windows Feedback" app and wait for it to be fixed.

  4. Use a third-party product, such as the CutePDF Writer that you have already tried and found to work properly, as a temporary solution until the problem is fixed by Microsoft.

As a sort of desperate measure, in case the 1511 Windows 10 update caused the problem, you could maybe find a post-1511 ISO and do a clean install of Windows 10. This is in the slight hope that some Windows component that wasn't fully updated before would now work correctly.

5
  • Thanks for the suggestions. I have done points 1-4 already. I don't feel like reinstalling fresh just to see if this stupid bug would be fixed however, it's not that important, more of a big annoyance I can live without. I just found it very sad that there was no known issues (with fix) already provided by Microsoft for this. I can't possibly be the only one affected by this ! – Yanick Girouard Jan 13 '16 at 16:30
  • If the problem happened only after the 1511 update, sometimes uninstalling it and reinstalling helps. This probably means that the 1511 update itself was flawed and subsequently updated. – harrymc Jan 13 '16 at 19:25
  • I tried that already to no avail. – Yanick Girouard Jan 13 '16 at 23:46
  • 1
    The solution then must come from Microsoft. Unfortunately I cannot see any more possible actions on your side than are in my answer. – harrymc Jan 14 '16 at 5:48
  • And windows 8 was properly tested ? – nicolas Apr 24 '16 at 16:19
1

On your question, you said that you tried to uninstall the feature using the 'Turning Windows features on or off', let's try another approach:

  • Search for Device Manager, or do Win + R and then DEVMGMT.MSC.
  • Go to 'Print queues' then uninstall both the PDF and XPS print queues.
  • Search for 'Advanced Printer Setup', or look this option in the Control panel.
  • Select 'The printer that I want isn't listed', in the next window choose 'Add a local printer or network printer with manual settings', select 'Use an existing port:' then in the dropdown select 'FILE: (Print to File)'.
  • In the next window, it will appear a list. Select Microsoft then in the second list select 'Microsoft Print to PDF' and next.
  • Select 'Replace the current driver' and then next
  • Give the printer a name (I suggest the original name) then next and it shall reinstall the printer and its driver.
  • Repeat the process but now instead of selecting 'Microsoft Print to PDF' in the list, select the XPS one.
  • Restart and see if it prints now.
4
  • Will try tonight and report back. Thanks for the suggestion ! – Yanick Girouard Jan 13 '16 at 16:27
  • Unfortunately, the above didn't work. I still get the same error (Test Page Failed to print) after I reinstall the printer manually with this method, followed to the letter. – Yanick Girouard Jan 14 '16 at 3:14
  • Run optionalfeatures.exe, uncheck Microsoft print to pdf and click OK. To reinstall it back, run OptionalFeatures again and place the checkmark back for Microsoft Print to PDF. – w32sh Feb 23 '16 at 12:26
  • Been there, done that. That's not it. – Yanick Girouard Jun 21 '16 at 11:57

Not the answer you're looking for? Browse other questions tagged or ask your own question.