1

I am trying to use multiple monitors with an rdp session on Windows 10(host), the source is on Win 7(guest) and a Hyper-V vm.

When I exec from cmd the following code mstsc.exe /span it works, but not my desired result.

However, when I try mstsc.exe /multimon nothing happens, and this is the desired effect.

Any ideas would be great, thanks!

1
  • So after looking inside the vm, it looks like it doesnt have a 2nd monitor available. This vm is hosted on my pc, so why wouldnt it have 2 monitors? And how can i add the 2nd?
    – tshoemake
    Jan 4, 2016 at 16:05

1 Answer 1

2

From mstsc.exe /?:

/multimon -- Configures the Remote Desktop Services session monitor layout to be identical to the current client-side configuration.

So to have two monitors in your RDP session while using this switch, you'll need two monitors set up on the RDP server (the VM in this case).

Edit:

User noted (after answer was posted) their VirutalBox tag was wrong, and that they're actually using Hyper-V as the hypervisor.

There is (currently) no way to add a second virtual display to a Hyper-V VM; So you're stuck using the mstsc /span option to utilize multiple monitors on the RDP client.

Orginal Answer (VirtualBox):

To add a second monitor to a VirtualBox VM:

  • Ensure the VirtualBox Guest Additions are installed in the guest OS.
  • Power down the VM.
  • Right-click the VM and choose "Settings..."
  • Choose "Display" in the left-hand panel.
  • Turn up the "Monitor Count" to 2 (you may need to assign more virtual Video Memory for each monitor you add).

enter image description here

3
  • Hi @Ƭᴇcʜιᴇ007 is this done in Hyper-V Manager?
    – tshoemake
    Jan 4, 2016 at 16:59
  • You tagged it VirtualBox, so I figured you meant VirtualBox. Now I note you ALSO tagged it Hyper-V. Perhaps edit your question to spell out exactly which Hypervisor you're using, and which OS the VM's guest and host are running. Jan 4, 2016 at 17:03
  • You're right, my apologies. I meant to tag virtualization :/
    – tshoemake
    Jan 4, 2016 at 17:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.