11

Description

Ever since upgrading to windows 10, I am having an issue with single left-clicks registering as double clicks.

I believe this to be a windows 10 issue, not a hardware issue. I say this because it happens on two separate workstations using separate but identical keyboard/mouse setups, which were purchased about a year apart so have substantially different levels of use on them (so should rule out unlikely failure of both mice).

Prior to upgrading to windows 10, I was using windows 7 on the work machine and windows 8.1 on the home machine never had any issues with the mouse registering single-clicks as double-clicks(ever). I've been using the home setup for ≈2 years and the work setup for ≈1 year.

After "upgrading" to windows 10 at home, I immediately started having this double-click issue at home (but still no problem at work, where I was running windows 7).

A few months later, my desktop at work died (it was about 5 years old) and I got a new desktop workstation at work, which is running windows 10. Immediately after getting the Windows 10 workstation I started having the same double-click problem.

So in summary: this happens on two separate workstations using two separate mice; I never experienced this issue at either workstation prior to installing Windows 10; I upgraded from windows 8.1 to windows 10 on workstation A, workstation B died (power supply and LOB failures) and was replaced with a new Dell workstation running windows 10; at both locations, the double-clicking was immediately a problem as soon as Windows 10 was introduced.

There are many issues regarding this over on the Microsoft Answer network, however all the Microsoft representatives seem to think this is a hardware issue, and don't go into troubleshooting steps other than "get a new mouse."

I'm hoping the SuperUser community may have some better suggestions!


Computer, Keyboard, Mouse Setup(s)

A (Work): Dell Precision T7810 (Intel E5-2650 v3 @2.3 GHz, 32GB Ram, 64-bit Windows 10 OS).
B (Home): Lenovo W540 (don't remember exact specs, will update later, 64-bit Windows 10 OS)

A & B: Both using Logitech MX5500 Bluetooth Revolution Keyboard and Mouse (two separate sets, one at each location). Both running Logitech Setpoint (most current version: Command center v6.67.83 / driver v5.90.41)


Steps Taken

I have tried (in no particular order, on both machines):

  • Change mouse double-click speed settings.
  • Change mouse cursor speed settings.
  • Turned off/on "Enhanced pointer precision" (normally off as I don't like this setting)
  • Changed driver (currently "HID-Compliant Bluetooth Mouse," also tried "HID-Compliant Mouse") and restarted PC. Changed back driver and restarted again.
  • Uninstalled Logitech Setpoint (Control Center v6.67.83; Driver v5.90.41)/ Reinstalled Logitech Setpoint.

EDIT: I tried a generic USB mouse and it does not seem to be having the double-click issue. However, the bluetooth mice still have this issue, and since I rely on the customized buttons for CAD work I would really like a resolution that doesn't involve redefining my workflow to use a more basic mouse; I've been able to use these bluetooth mice just fine for the last 2 years on Windows 7, 8, and 8.1, so this still seems like a Windows 10 problem to me. .

NOTE: Sometimes playing with the mouse settings will seem to fix it for a day or so, but a day is about the most I'll get of usability before it starts re-occurring again (usually starts of with a low number of random clicks being double-clicks and gets progressively worse very quickly).


Misc.

To be clear, I have two of the same keyboard/mouse combo sets, one at each location, not one pair moved between locations; these were purchased nearly a year apart, to have very different amounts of use/wear on them.

I've done quite a bit of searching on this issue. I did read 3-4 other similar threads on this site an in one of the threads someone asked if this is really a problem. Yes it is a very real problem.

Right now my mouse double-clicks around 8/10 times, this makes it almost impossible to get anything done in some programs, and is extremely frustrating the rest of the time. For example in Solidworks, which I use heavily at work, a double-click cancels a new sketch entity and makes it impossible to select an entity [instant deselection by the second click]; In Microsoft Word and Outlook, I can't highlight the text I need to as the double-click maddeningly causes whole words or paragraphs to be selected/deselected; in any program that uses option boxes it is infuriating to work with as the second click instantly changes the option back to what it was before clicking; etc.

  • 1
    Have you tried a different (USB) mouse on either of the PCs (just to rule out mouse issues). – DavidPostill Jan 4 '16 at 17:39
  • 1
    I haven't tried a USB mouse because I don't own one (haven't needed one in over 3 years). I'll see if I can wrestle one up at the office and give it a go today. – CBRF23 Jan 4 '16 at 17:45
  • Okay, I got a USB mouse and id does not seem to be having double click issues. I have both mice connected and while the Logitech bluetooth mouse seems to be giving me issue, the generic USB mouse does not. I'm wondering if this is an issue with the bluetooth driver - the USB mouse is running "HID-compliant mouse" and the logitech one is running "HID-compliant bluetooth mouse". I previously tried running the logitech with the non-bluetooth driver, it works but not all buttons worked and I think, IIRC, it was still giving me double-click issues. – CBRF23 Jan 4 '16 at 17:53
  • Check folder options>General Tab, make sure single click is Not ticked – Moab Jan 4 '16 at 19:12
  • Double-click is checked (I just looked to confirm). – CBRF23 Jan 4 '16 at 19:14
6

There are a few suggestions running around that this is a hardware problem with Logitech mice.

Two ways to reduce the problems (probably will reappear eventually) are proposed:

  1. Try removing the mouse batteries. Then click the mouse buttons repeatedly for 30 seconds. Then put the batteries back in. Why? Apparently this could drain any static electricity stored in the capacitators of the switch. This is all second hand information, give it a try and if it doesn't work try 2).

  2. This fix involves putting a piece of tape on between the two moving parts (the button and the switch). This solution is described here https://www.youtube.com/watch?v=9leRzMPhJQ0 (no disassembly required for some mice) or here https://www.youtube.com/watch?v=0eJblRVSQ7U (disassembly required)

In case youtube links go down, here are the steps (images taken from the non-disassembly video)

Lift the mouse button (or disassemble mouse if required). enter image description here

Cut a little piece of tape and stick it to the plastic plunger. enter image description here enter image description here enter image description here

Press the button back down (or re-assemble mouse). The mouse is now fixed.
enter image description here

|improve this answer|||||
  • I'm amazed: draining capacitors fixed the issue for me. – v.grabovets Aug 28 '18 at 8:30
4

I was just having the same issue in Windows 10, and noticed in the Device Manager that I had two HID-compliant mouse entries under the "Mice and other pointing devices" tab.

I went ahead and uninstalled one of them and I no longer seem to be having the double click event problem.

|improve this answer|||||
1

I had similar issues with a Two different logitech mice on Windows 10. I've corrected my issue (or it seems to have improved) by disabling the power management settings on each USB Root Hub device in Device Manager (devmgmt.msc)

Start > Run (or Windows Key + R)
 devmgmt.msc > [OKAY]
 Universal Serial Bus Controllers>
  Properties of each USB Root Hub device.>
   Disable "Allow the computer to turn off this device to save power"
|improve this answer|||||
0

It's a long shot, but the following worked for me (on Windows 8.1, but as it appears to be a hardware problem, it doesn't really matter).

There's a small program called MouseFix written by Daniel Jackson (source code available), that's implements a global mouse hooks that filters the redundant clicks based on a threshold. The essential logic looks like this:

#pragma data_seg(".SHARDATA")
static DWORD lastTime = 0;
#pragma data_seg()

#define THRESHOLD 40

LRESULT CALLBACK MouseProc(int nCode, WPARAM wParam, LPARAM lParam) 
{
    bool block = false;
    if (nCode == HC_ACTION) 
    {
        PMSLLHOOKSTRUCT pMsllHookStruct = (PMSLLHOOKSTRUCT)lParam;
        if (!pMsllHookStruct)
            return CallNextHookEx(hHook, nCode, wParam, lParam);

        DWORD currentTime = pMsllHookStruct->time;
        DWORD elapsedTime = currentTime - lastTime;

        switch (wParam)
        {
        case WM_LBUTTONDOWN:
            if (elapsedTime < THRESHOLD) 
                block = true;
            break;

        case WM_LBUTTONUP:
            lastTime = currentTime;
            break;
        }
    }
    return !block ? CallNextHookEx(hHook, nCode, wParam, lParam) : 1;
}
|improve this answer|||||
-1

It's my opinion this is a windows problem. In the device manager I uninstalled all mouse HID (including the hiding devices) except the mouse I was using. This solved the problem.

Previously I had tried other mouses but had the same symptoms (or similar) problem. I suspected this was not a hardware problem since I run 2 computers with the same mouse and keyboard using a USB commutation device. The computer with Linux did not display the ''one click'' problem but the one with Win10 did.

Hope this will be helpful.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.