0

I just tried using my USB flash drive on my Android Device via USB-OTG, and it worked great. However, I tried re-connecting the drive to a computer, and these strangely-named files appeared. They are undeletable via both Windows Explorer AND command prompt, and I'm not quite sure if they are malicious. I can access the rest of the files on the drive normally, but I can't move, copy, or delete the files in question from the drive. What are these files, and are they a necessary part of the drive?

The undeletable files

  • Here's what happens when I try to delete the file normally. imgur.com/KzBA4m9 – Jonathin Jan 4 '16 at 20:08
  • Looks like the file names contain international (asian, arabic of sth like), so ist cannot be processed by an "european" or US Windows. Did you try to rename the file, or delete the file using wildcard-characters from the Commander line? – user3767013 Jan 4 '16 at 20:21
  • I tried renaming the file, but it gives the same error message... – Jonathin Jan 4 '16 at 20:30
  • To me it looks (and sounds) like the files and/or file-system on the drive are corrupted. From Windows, run a chkdsk against the USB drive and see if it reports any errors, if so use chkdsk /f to attempt to repair the problems. – Ƭᴇcʜιᴇ007 Jan 4 '16 at 21:09
1

Copy off any valid files and reformat the USB drive (full, not Quick format), to salvage the drive; be sure to use the correct format for the device. One way the files could have been created is if the flash drive used a format that the device did not understand, e.g. exFAT.

  • The file names are part of the FAT/inode table which would be destroyed as part of a quick format, no need to write over the whole stick, which would cause unnecessary writes to fragile memory. – Ed Neville Feb 21 '17 at 19:33
0

You can also try using the USB Stick on Linux again and see if you can detect the files and attempt to delete them. They were most likely created in a Linux environment anyways.

  • While Android is Linux based, I did not create the drive on a linux computer. And while it did take a while to backup all of my files, DrMoishe Pippik's solution did work out in the end. Since then, I have not been able to replicate the issue. – Jonathin Feb 21 '17 at 19:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.