0

With few applications - either old or open source, I have this problem with OS smoothing inner area of window. Everyting is smoothed. This makes using Emacs-w64 very painful and I am forced to use notepad++ because it doesn't have this smoothing problem. If I turn off smothing system-wide, it turns out very ugly, even worse then smoothed.

I don't know if that is clearType or something else, because it appears in some applications and does not exist in other.

Only inner window area is smoothed, header of window is not smoothed.

example lossless cut-off from screen

This looks like a bug, my suggestions were that inner area is put in some kind of system buffer and then transferred to another buffer and in-between of that transactions smoothing is applied. May be some DirectDraw buffers?? Because many applications which do text rendering, Notepad for example - are using standard procedure for text rendering (ClearType) and does not show this behaviour. Applications which control everything by itself, doing fine too.

4
  • This forum of Emacs tag is rarely used by anyone, and when it is used, it should be a question -- not a feature request. Perhaps this would be a better issue for M-x report-emacs-bug. It is also unclear what specifically is a "header" in the context of your feature request. Is it the line that says emacs@TEREBRUM, or is it the menu bar, or is it the toolbar buttons? The latter two can be removed entirely if seeing them is problematic. I am obsessive compulsive about many things, but I honestly don't visually see an issue with the image you posted. – lawlist Jan 5 '16 at 14:07
  • It's not clear what problem you are describing. Like @lawlist, I see nothing "smoothed", and I have no idea what you mean by the "inner" window. Maybe you are talking about the fringe? My suggestion: clarify the question or it risks being closed as unclear. – Drew Jan 5 '16 at 21:51
  • If you are talking about anti-aliasing (e.g. ClearType) then I don't know what "inner" area you mean. For me (on MS Windows 10), ClearType does not affect Emacs negatively. But the effect it has probably depends on the font you use. – Drew Jan 5 '16 at 21:53
  • It is still a question why "automatic resizing" happens on my win10 computer and not on win8. Probably screen DPI has some interfering. – sanaris Jan 6 '16 at 5:53
0

I have found one round up: in "Compatibility" properties of ".LNK" file check in box "do no rescaling". This is third checkbox from "Parameters".

Also I put "windows 8" checkbox just to be sure. Because in Win8 that did not occure.

Description: "Turns off automatic resizing of programs if large font sizes are used. Try this setting if large-scale fonts are interfering with the appearance of the program."

Also I found that could be done via regedit. Recipe from tenforums.com.

Would be great to know how to do that from CMD perspective. But solved! Other old text editors are working as well too! "SourceInsight3" for example.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.