0

Backed up all files, erased disk (partition) reinstalled OS that came with machine (snow leopard - was informed that that was the OS that came with the machine originally and that one had to be installed). Default apps installed.

Tried to reinstall from TMBackup, told OS needed to be updated as apps wouldn't run on OS just reinstalled. Updated to El Capitan and tried to reinstall all apps and data.
Data transferred ok, but no apps, not even default ones, were installed. Can't even connect to Internet to replace anything.

What happened? How can i fix it?

0

Time Machine is a complete system backup. There is no need to reinstall an operating system prior to doing the restore. In fact, it works better if your hard drive is just completely blank.

Here's what to do:

  1. Boot your Mac to OS X install media. It does not matter which version (although if you have a Snow Leopard disc that would be convenient).
  2. From the main menu, choose Disk Utility.
    enter image description here
  3. In Disk Utility, choose your internal hard drive from the list on the left (not the partition(s) on it). Then choose the Erase tab from the screen on the right. Select Mac OS Extended (Journaled) from the format box and give it a name. Then hit the erase button.
    enter image description here
  4. Once that's done, close Disk Utility and you'll be back at the main menu. Choose Restore from Time Machine Backup.
    enter image description here
  5. Just follow the wizard from there, selecting the source and the destination.

It should restore your entire system exactly the way is was when you last backed it up, including the operating system.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.