Since the fall update last month, Windows 10 automatically keeps changing the default apps for certain types (mostly browser,pdf,mp3,jpg). I have tried changing them back from the Settings app as well as the Control Panel.

I have observed that this happens mostly while unzipping files using WinZip. Windows changes the default programs back to Microsoft recommended programs such as Edge, Photos, Groove etc.

Is there a way to restrict this from happening? Has anybody else encountered a similar situation? I couldn't find similar question anywhere so I'm asking this here.

  • Has this happened more then once since you install Version 1511 update? That is the only time it happen to me, took less then a minute, to set my configuration back though and it only happened because of the way I installed the update.
    – Ramhound
    Jan 5, 2016 at 13:17
  • 1
    @Ramhound: yes this has happened quite a number of times which is why i'm seeking some solution to it. it gets frustrating.
    – kp91
    Jan 5, 2016 at 13:19
  • See also here. May 25, 2016 at 21:05
  • I suggest running "ASSOC" and "FTYPE". Output to a text file. Then, if changes do get made, you can easily look up older changes. You can also make a batch file to easily manually fix changes that seem to break the most, or which you simply care about the most.
    – TOOGAM
    Jun 11, 2016 at 6:07

12 Answers 12


I've had this problem frequently but randomly. I was finally able to track down one set of triggers for the issue, but not a direct fix... only hackish, partial workarounds.


For example, "Groove" or "Movies & TV" will try to grab the associations of music and video formats. The only solution I have found is to uninstall these seemingly uninstallable programs.


The above article describes how to use (admin)Power Shell to temporarily uninstall some Microsoft installed apps.

For example:

Get-AppxPackage *zunemusic* | Remove-AppxPackage


Get-AppxPackage *zunevideo* | Remove-AppxPackage

After uninstalling these apps, Windows 10 has never tried to re-take these file associations. I was half expecting it to try regardless and break the associations completely, but was fortunate.

Unfortunately this will not fix all of these problems. PDFs will continue to revert to Microsoft Edge because it cannot be uninstalled by this method.

Trigger cause:

I was able to track down a trigger that causes this to one of my programs. Though I'm not certain that it is the only one that does it as it only causes some associations to change. So more likely it is certain actions that the program causes sets up the first trigger; and another program completes the trigger sequence.

According to procmon, it does some registry snooping with file associations. The second trigger is to open a program that is associated with a file type that often reverts. That second program also snoops at file associations according to procmon.

What I imagine happens is that the first program does something to corrupt the "protection" Windows 10 has for programs changing file associations. Opening the second program causes Windows to re-check its protection and when the hash/progid ends up being invalid, it gets reverted to Microsoft defaults.

For example, I can see an old version of PhotoShop and Firefox doing this. They both look at the key


Program 1 messes up the hash/progid somehow, Program 2 which is associated with the type makes Windows re-check it and revert it. I'm a little mystified as to why it's deemed corrupted to begin with because the file association is correct before and after Program 1 does its thing. The association wasn't hijacked, so it didn't need Microsoft's overreach to begin with.

Not all of my systems have the same programs installed, so I'm guessing there may be many esoteric old programs that cause the first trigger event. Aside from my original workaround above, I guess you could be mindful using the offending programs. (shrug)

  • Can you specify what you did to identify the trigger cause? Did you use any specific program or application?
    – Ayusman
    Sep 26, 2017 at 6:05
  • 1
    @Ayusman I mentioned above, I used Procmon from Sysinternals/Microsoft. I probably had it filter to the programs in question and also if the "path" had 'pdf' in it.
    – jljtgr
    Sep 29, 2017 at 0:14
  • 1
    This is not an answer to the issue. I’m not sure why it has gotten so many upvotes. Nov 13, 2018 at 2:40

An explanation and solution is given at ghacks.

You can either use Stop Resetting My Apps which was developed to stop this resetting

Stop Resetting My Apps

or modify the registry by hand.

So, here is what you need to do for that if you prefer the manual way:

  1. Tap on the Windows-key, type regedit.exe and hit the Enter-key. This opens the Windows Registry Editor. If you can, open a second Registry window for easier handling of the following operations.
  2. Navigate to the following key: HKEY_CURRENT_USER\SOFTWARE\Classes\Local Settings\Software\Microsoft\Windows\CurrentVersion\AppModel\Repository\Packages
  3. Locate the application you want to block from being the default, and open App\Capabilities\FileAssociations there. This displays the list of file associations of that particular application.
  4. Take note of the value in Data, it looks like a long random string: AppXsq3757nydv3f9bx6862hv0t4z7ennqqd
  5. Please note that this string may be different for any of the file types or protocols listed there.
  6. Switch to the second Registry Editor window, and go to HKEY_CURRENT_USER\SOFTWARE\Classes\ThatRandomString, e.g. HKEY_CURRENT_USER\SOFTWARE\Classes\AppXsq3757nydv3f9bx6862hv0t4z7ennqqd
  7. Right-click on it, and select New > String Value.
  8. Name it NoOpenWith, and keep its value empty.

Repeat the process for any file association that you don't want that particular app to be ever associated with again.


Several apps like Edge, Groove or Photo took over control of your files when you upgraded to Windows10, you will then not be able to choose your own software of your liking to open your files. BUT this behaviour can be stopped if you add a setting to your registry to Exclude E.g. Edge as an "available" file handler for PDF files. Following will stop Edge for blocking the use of Acrobat to open PDF files and other software like FIREFOX to open HTM and HTML files (I use the word BLOCK because Edge acts like a VIRUS, it always resets the file association back to Edge, even my 20th attempt to associate Acrobat Pro or Reader was re-set after a few hours, sometimes seconds.. ). Now to the Regedit setting. You need to look-up the associated PROGRAM-ID inside the registry AND then create a new key for the FILE TYPE you want to exclude from that program. The following entry....

[HKEY_CURRENT_USER\SOFTWARE\Classes\Local Settings\Software\Microsoft\Windows\CurrentVersion\AppModel\Repository\Packages\Microsoft.MicrosoftEdge_25.10586.0.0_neutral__8wekyb3d8bbwe\MicrosoftEdge\Capabilities\FileAssociations]

...shows that for PDF
is that PROGRAM-ID.

Now you go to...
HKEY_CURRENT_USER\SOFTWARE\Classes\AppXd4nrz8ff68srnhf9t5a8sbjyar1cr723 (note the same ID) and create a new STRING key NoOpenWith (leave it empty)

EXAMPLE (as long as MS does not change the IDs) the following will stop Edge to hijack .HTM .HTML and .PDF files:

Windows Registry Editor Version 5.00



(you can copy this to a text file, change extension to .reg and import it to your registry.)
If you remove those 2 keys NoOpenWith again, it will revert to original setting.


I switched to the latest version of WinZip (20.0) and haven't encountered the problem since. So i guess the previous version (15.0) was in some way incompatible with Windows 10 file associations and triggered the reset.

  • Yes. The WinZIp Knowledge Base words things to make it appear that Windows 10 is the problem, but the problem is actually that WinZip messing with file associations in the first place. And why is it messing with the associations of types that are not archives?
    – Medinoc
    May 15, 2018 at 14:46

I've found a way prevent edge from becoming the pdf / html handler. It's possible by adding the Noopenwith value for Edge's ProgID (the AppX..... key, this may vary from system to system). More details on it here. How to Stop Edge From Hijacking Your PDF or HTML Associations? The same method works for any other app.

  • 1
    Please quote the essential parts of the answer from the reference link(s), as the answer can become invalid if the linked page(s) change.
    – DavidPostill
    Feb 13, 2016 at 9:55
  • This article leads to another that has an easier version of the fix, a downloadable regedit file to insert the appropriate registry changes (and another to undo them). link Apr 23, 2016 at 20:03

This problem is likely caused by KB3135173 update (from February 9, 2016). The workaround is to uninstall the update and block it from reinstalling by using "Show or hide updates" troubleshooter package.

Source: @Jukin.Kei post at An App Default Was Reset at Microsoft Answers.

Related: Windows 10 now blocking IrfanView at Reddit.

Other workarounds:


Also see that thing (update / install program that can open some files can lead to that dialog, if not disabled) http://www.tenforums.com/software-apps/14819-windows-asks-default-program-even-after-being-set-disable.html


Here's another cause of this, for me at least:


All was working well when I installed the original version of Windows 10,

But now when I recently re-installed:

Microsoft Windows [Version 10.0.15063]

SageThumbs did not work as expected and this problem appeared, I un-installed it, rebooted, set default apps, rebooted and problem is gone now :)

I opened an issue here for that problem.

By the way, it also appears that:

Winamp 5.666

Does not work well anymore, as it does not appear as an option to be the default app for music.


UI automation of the Settings app seems like, unfortunately, the best option here.

I created a simple AutoHotkey (AHK) script to set my browser to Firefox on startup (you need to compile the AHK script first, then I just set it to run "late" after login). The browser is determined by the number of TABs to get to your browser of choice.

Tested on Windows 10, build 1809.

; Fix default browser

    Sleep 1250
    SendInput {RWin}
    Sleep 1000
    Send Default apps
    Sleep 3500
    Send {enter}
    Sleep 3500
    Send {tab}
    Sleep 250
    Send {tab}
    Sleep 250
    Send {tab}
    Sleep 250
    Send {tab}
    Sleep 250
    Send {tab}
    Sleep 250
    Send {enter}
    Sleep 2000
    Send {tab}
    Sleep 250
    Send {enter}
    Sleep 7500
    Send !{F4}
    Sleep 100

Some of the fixes described here in 2016 do not work in newer Windows 10 versions (1809 or later). So here is what I did today to fix the problem, which manifested itself in our domain network by resetting the default PDF viewer around every hour.

First, find out which program tries to write to the registry key


As described here, writing to this key directly is not prohibited any more, it causes Windows to reset the file extensions to its defaults. I found the exact process and its access time using Sysinternals ProcessMonitor (set a filter to show only operations of type RegSetValue to the named key).

In my case, the process was "svchost.exe", which indicates some of the background services caused the issue. Next thing I did was looking into the windows logs, which showed me that the only service which was started at that point in time was the Group Policy service of our domain. Finally, by looking into the Windows logs of the GPO service, I tracked it down to two potential services, of which one had a name which looked very suspicious.

I forwarded this information to our network administrators and based on that information they could fix the issue in less than one hour.


I got rid of Windows resetting the default apps (in my example: for movie and image filetypes) by simply removing the Windows 10/11 apps for these types, namely "Photo Viewer" and "Windows Media Player" (both are buggy, don't support essential codecs and are otherwise out of date anyway).

Photo Viewer to prevent it from messing with image file extensions: in Start Menu, run Powershell and type:

get-appxpackage *Microsoft.Windows.Photos* | remove-appxpackage 

Media Player to prevent it from messing with movie file extensions: Start Menu - Settings - Programs and Features - "Turn Windows features on and off" - uncheck "Windows Media Player" in the "Media features" branch.


Another potential solution is to change what your default associations are, so that when windows DOES revert to default associations, it reverts to what you want it to be.

See https://technet.microsoft.com/en-us/library/hh825038.aspx

DOES THIS APPLY TO WIN 10? Heading of the linked page does not say that.
For windows 10
After the installation of KB3135173 and how to

  • Welcome to Super User! Please quote the essential parts of the answer from the reference link(s), as the answer can become invalid if the linked page(s) change.
    – DavidPostill
    Apr 8, 2016 at 9:30

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .