3

When I'm trying to copy or move files to a system directory (like C:\Program Files or C:\ProgramData\Microsoft\Windows\Start Menu) nothing happens instead of being prompted for access rights with the usual UAC dialog. The files are not copied/moved and there is no error message.

Here's the story behind it:
I got a new PC with Windows 10 installed. There was already a user account "user" created, but I wanted my own account "Florian" with my own name. So I created my account in Administrative Tools and added it to the Administrators group. I switched to my new account and deleted the old "user" account.

User accounts

Since then I started to setup my PC and install my programs. I tried to copy some portable programs to C:\Program Files when I noticed that I could not simply copy a directory into C:\Program Files. I expected a UAC prompt, but I only got the wait cursor for the fraction of a second and nothing happened. I cannot even delete directories from installed programs.

My user account has no permissions except "special permissions" for C:\Program Files, but as I am in the Administrators group I should be able to modify files there. I checked this with another Windows 10 installation and the permissions are the same.

Directory permissions

I get the regular UAC prompt when modifying system settings running programs "as Administrator".

Any ideas why I am not prompted for permission when copying to system folders?

  • 2
    Please translate the screenshots into English for us. – Ramhound Jan 5 '16 at 13:42
5

After some experimenting I found the solution: TortoiseCVS installed s shell extension which in some mysterious way prevented the UAC dialog. After uninstalling TortoiseCVS it worked again. To confirm it, I installed TortoiseCVS again and the problem was back.

Unfortunately, TortoiseCVS hasn't been updated in years and even the last release candidate does not solve the problem. I guess I need another CVS client on Windows 10...

| improve this answer | |
  • Nice find! If you want to keep Tortoise but fix the problem, you can remove the icon overlay. See my answer. – Ben N Jan 6 '16 at 17:00
  • From user Trance: It wasn't the overlays, I just repro'd on win10, and it was the TortoiseShell.dll\TortoiseShell64.dll extension. – fixer1234 Jan 6 '16 at 18:07
  • Gov Maharaj (@trance) answered it in his show: channel9.msdn.com/Shows/The-Defrag-Show/… – magicandre1981 Jan 17 '16 at 17:01
  • Holy cow, this also fixes the problem of the directory conflict dialog not appearing. – isanae Feb 13 '16 at 17:29
4

We have resolved the technical issue behind the loss of UAC prompts when using TortoiseCVS in Windows 10.

Our bug number for this issue is 6978: http://customer.march-hare.com/webtools/bugzilla/ttshow_bug.cgi?id=6978&tt=1

The problem is resolved in CVSNT 2.8.01.6002 and later releases.

You can download the latest release here: http://march-hare.com/cvspro/

Regards,

Arthur Barrett

Product Manager CVSNT

| improve this answer | |
1

As the original poster's answer noted, the problem is caused by TortoiseCVS. If you want to fix the problem but keep the program, you can remove the shell extension.

Find Tortoiseshell64.dll in the TortoiseCVS program files. Renaming it will cause Explorer to not be able to load it, thus fixing the problem. Alternatively, you can use Sysinternals Autoruns to disable the shell extension and stop Explorer from even trying to load it. (It will be on the Explorer tab under one of the ShellEx headers.)

| improve this answer | |
0

I ran into this same issue with TortoiseCVS on a new Windows 10 system. As I started exploring various options, I found out that this problem is no longer faced if I turn UAC completely off on the Windows 10 system.

I have done the following two changes for this purpose:

  1. Setting User Account Control Settings to Never Notify
    (http://windows.microsoft.com/en-us/windows/turn-user-account-control-on-off)

  2. Setting User Account Control: Run all administrators in Admin Approval Mode option to Disabled in Local Security Policy (https://technet.microsoft.com/en-us/library/jj852217.aspx)

This is a workaround but it might be helpful for those people who can work with keeping UAC turned off. With this workaround, they can at least continue to use TortoiseCVS smoothly without running into this issue.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.