2

I am a new linux user. I recently bought a new sata hard disk of 160gb. I tried installing fedora on it but it failed. Tried installing debian on it but it also failed since the installation process stopped in the midst of installing. I went to the seller for him to check it out.It turned out to be a faulty sata cable which he replaced and he successfully installed Windows 7 on it on the first go.

After that I formatted windows and installed fedora 23 xfce spin on my old computer with 2gb DDR2 ram and then I was able to successfully install it. For first day I ran it for a short period of time and it worked fine but on second day when I left it on for downloading a file from my server, I checked it in the morning and its screen saver gave me no option to enter my password to login. I resorted to turning it off via pressing the power button.

Third day when I turned it on again and used for 2 hours it froze giving input/output error. Tried to install google chrome, tomahawk music player it gave input/output error after downloading the packages. Whether I clicked on any icon, even terminal, any file, it gave input/output error. Fourth day after 10-20 mins of use it froze and again gives input/output error.

I tried running dmesg when the system gave the error but it also gives input/output error.

Thankfully, I was able to click on shut down button when it gave errors like this in dmesg:

    Input/output error on block 233171008
    Input/output error on block 233171008
    Input/output error on block 242061800
    Input/output error on block 242061928
    Input/output error on block 242061928

I tried running fsck from a live usb running fedora and it gives output of file system as clean. It freed some inodes but that's all.

Tried e2fsck; it also gave same output i.e clean. It also freed some inodes and that's all. I forced running again but this time it just displayed it as clean.

I thought I had problems with my installation but it looks like its all good. Help please!

  • 2
    While it's possible in principle that you're hitting a kernel bug or FS driver bug, that would be unusual to show up in a stable release, and would probably affect a lot of users. My guess is your HDD is bad. – allquixotic Jan 5 '16 at 19:38
  • 2
    Replace the HDD. – Ramhound Jan 5 '16 at 19:44
1

This is almost certainly actually due to a problem with the new disk. Disk failure follows a bathtub curve, so failures early on are common.

You could get further verification by installing smartmontools (if not already installed), and then running smartctl -a /dev/sda. But, mostly, since your disk is new, I'd say to return it immediately for replacement.

| improve this answer | |
  • Actually, I don't think the problem is with the disk, but problem is with Fedora. I am facing this very same issue on my Inspiron laptop (Input/Output error after a few minutes of usage). And guess what? This happens only with Live usb of Fedora, not Ubuntu, not Debian, not openSUSE, I've tried them all! – Prahlad Yeri Jan 18 '16 at 20:52
  • Wait, hold on. Is this all on a live USB? From your question, I thought that was a diagnostic tool you used. – mattdm Jan 18 '16 at 21:13
  • Yup. I'm using live USB to try out f23. After 10-20 minutes of usage, I get an I/O error whenever I try to open a program or give a terminal command. When I shut down, this is what the console says. (I'm not OP, btw). – Prahlad Yeri Jan 19 '16 at 6:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.