22

I want to set a different custom scaling level for each of my 2 monitors.

The "recommended" scaling for my laptop display is 150%, while 100% scaling is recommended for my external monitor. 100% is great for my external monitor, but 150% just makes everything too big on my laptop display.

From what I could find searching google, it appears that there are 3 ways to change monitor scaling. Only one method allows for different scaling for each display, but this method only allows for scaling in increments of 25%, and unfortunately 125% is too small for my laptop display, and as I said 150% is too large. The other two methods, while I can set the scaling to any percentage I want, scale both monitors at once and do not have an option to scale them separately.

Ideally I would like something like 140% scaling for my laptop display and 100% for my external display. Does anyone know if this would be possible and how I could go about doing it?


Details

Below I will describe in more detail the 3 scaling methods I've mentioned so it's more clear what I've tried.

  1. The simplest way to change the scaling is to right click on the desktop and choose display settings. As shown in the screenshot, the slider only allows for increments of 25%, and I need scaling in between 125% and 150%

    The slider only allows for increments of 25%

  2. The second method Is to click "Advanced display settings" at the bottom of the window from the first option, and then click "Advanced sizing of text and other items", and finally "set a custom scaling level". This would be perfect, as you can choose any percentage you want, except when you do this it sets both monitors to the same scaling level.

  3. Finally, you can go through the registry and the results are the same as number 2. Win+R > regedit > HKEY_CURRENT_USER > Control Panel > Desktop > Win8DpiScaling

4
  • 1
    Did you find a solution? I want to know it, too.
    – Welcor
    Sep 9, 2017 at 12:04
  • @blechdose nope I never did find a solution, sorry to disappoint
    – Takaia
    Sep 11, 2017 at 2:29
  • In your description of 2, you said to click "Advanced display settings." Either this is an error, and you actually meant to say to click "Advanced scaling settings," or this has been changed by Windows update and specific versioning info will be important. (I only mention this because "Advanced Display Options" is actually a separate button on the same page (at least in Windows 10 1903)
    – JCD
    Jun 8, 2020 at 19:28
  • 1
    I have same issue. I want 150% on 14" laptop (1920x1080) and 110% on external 27" monitor (2560x1440)
    – d-_-b
    Jan 6 at 22:23

2 Answers 2

0

First, as a precaution, disable UAC but via gp edit and policies:

Windows Setings/Security Settings/Local Policies/Security Options

User Account Control: Admin Approval Mode for the Built-in Administrator account    Disabled
User Account Control: Allow UIAccess applications to prompt for elevation without using the secure desktop  Disabled
User Account Control: Behavior of the elevation prompt for administrators in Admin Approval Mode    Elevate without prompting
User Account Control: Behavior of the elevation prompt for standard users   Prompt for credentials
User Account Control: Detect application installations and prompt for elevation Disabled
User Account Control: Only elevate executables that are signed and validated    Disabled
User Account Control: Only elevate UIAccess applications that are installed in secure locations Disabled
User Account Control: Run all administrators in Admin Approval Mode Disabled
User Account Control: Switch to the secure desktop when prompting for elevation Disabled
User Account Control: Virtualize file and registry write failures to per-user locations Enabled

If you experience some problems you can relax "Admin Approval Mode for the Built-in Administrator account" to "Enabled" as long as you keep "Elevate without prompting".

Then - separate the screens. Doesn't matter which one if 1st, which 2nd and along which edge they connect as long as they are separate - not replicas. Then just click one and adjust and then the other and adjust. Clicking the one you want to change is important.

If one is laptop, don't just close the lid - go to hibernate, with the lid open. That preservers all settings intact. If you disconnect one monitor, it's going to merge them. If they ever get merged again you'll be back to square 1.

Oh and the version of the OS might play a role, meaning that if you are on Home you might be screwed and if you are on LTSB you are guaranteed not to have any problems. Also if you have "Creators edition" you might get screed and the only solution is to go back to "Anniversary" or LTSB.

Also, check the "discrete" graphic card driver settings to make sure that there's no some leftover option there that's tying them.

I've been running with different scaling at work from the day one. But I don't take that laptop home. If I do, then I have to set it up again.

1
  • 2
    Are you running different CUSTOM scales for your monitors or PREDEFINED? (the ones that you pick via dropdown menu with 25% increments) Sounds like it's the latter..
    – vanowm
    Jun 2, 2020 at 23:38
0

Just curious if you happen to be running Intel graphics. There's a handy utility called Intel HD Graphics Control Panel that will do what you are asking about. It will also allow you to scale properly when using a 1080p or 720p HDTV as a second monitor.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.