26

I upgraded my Firefox to version 43 and it keeps showing black squares on my display. This black squares keep showing even when I'm using other programs. but as soon as I close Firefox, they go away.

Is there any solution for this?

I'm using Win7 x64 and Firefox 43 which is the latest version (as of 01/06/2016).


P.S: Screenshot: ScreenShot

  • 2
    Can't repro on firefox 43.0.3/64 bit. Screenshots would be handy – Journeyman Geek Jan 6 '16 at 4:28
  • 1
    what video card brand/model and driver version? – Richie Frame Jan 6 '16 at 12:39
  • 5
    I thought this was me! finally a solution. – Martijn Jan 6 '16 at 13:16
  • 1
    @RichieFrame I'm using ATI graphic card (1GB) – undone Jan 6 '16 at 18:34
  • 1
    I had a similar problem with Internet Explorer 11 and the same OS, just it was horizontal lines. +1 for asking. – wizzwizz4 Jan 6 '16 at 18:47
31

Your screenshot is displaying glitchy, repeating patterns of video artifacts which are characteristic of video RAM artifacts.

If your computer screen is displaying video RAM artifacts, then it would show up first in applications that use a lot of RAM, like Firefox. If the RAM in your graphics card is failing, sometimes just a small fraction of the RAM goes bad while the rest of the RAM continues to work properly.

As a workaround in Firefox, click the Firefox Main Menu button IMG: in the top-right corner of the screen. Go to Preferences -> Advanced -> General tab, and under the Browsing heading uncheck the option Use hardware acceleration when available.

Update

The update to Firefox 54 enabled multiprocess support for content, including a GPU acceleration process. If your GPU has hardware defects, the separate GPU acceleration process can cause crashing as well as visual artifacts on some websites. On the other hand, this provides an additional source of information that helps to more easily diagnose possible GPU hardware defects.

  • 12
    While this is characteristic of failing hardware, it can also just be a video driver error: transferring to or from the wrong region of memory. – pjc50 Jan 6 '16 at 15:38
  • It could also be a bug in Firefox; there have been plenty of bugs on the Firefox side with similar symptoms ever since hardware acceleration has made its appearance a long time ago. – RomanSt Jan 6 '16 at 21:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.