In my current project, we have been using Juniper Network Connect to connect to client's VPN. It's a web based VPN authentication that uses Juniper Network Connect to establish connection. I don't know any more technicalities.

Everything used to work as long as I was on Windows 7 and Windows 8.1. I have upgraded to Windows 10 today and since then the VPN stopped connecting. Earlier, after providing the username/password a small pop used to flash and go (saying Launching Network Connect) and established connection. But now after upgrading to Windows 10, the page throws me back to the login page even after giving the right username/password. No pop shows up. I have tried all Chrome, Firefox, IE. I used IE 11 earlier on Windows 8.1 and it worked fine. But nothing helps now.

Is Juniper Network Connect not supported on Windows 10? Can anyone guide me how to get this fixed?


2 Answers 2


I spoke to the support team of the client I work for and the issue turned out to be with the System time set on my machine. It was set to China timezone by default and I didn't notice that. After I changed the time to US the Juniper connect worked fine and my VPN now works fine.


Am I too late to try answer your question?

Try this link below, download the windows installer.


Hope this help.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .