3

Is it possible to use GPU acceleration when playing video in Google Chrome? I tried playing a 4K video in youtube using Google Chrome, and my laptop was quite laggy. I found out that my CPU usage became 100%, and this was the reason of it. I did check the "Use hardware acceleration when available", but the problem still persists.

Contrast to Firefox, when I played the video there, the CPU usage went to around 30-40%, with "Use hardware acceleration when available" settings turned on, and I can watch the video smoothly.

The experiment is done in Google Chrome version 47 and Firefox version 43.

My laptop video cards are Intel HD Graphics 4000 and GeForece 640M LE. Both of them should be capable of playing 4K video smoothly.

[Update]: Even IE11/Edge is also able to play the video smoothly. So only Google Chrome has this problem.

2

You could enable hardware acceleration by enabling a additional feature :

1.Type chrome://flags in new tab of chrome

2.Search for Override software rendering list

enter image description here

3.Enable and restart chrome browser

Note : the chrome might consume more memory on task manager due to the extensions which you have loaded with chrome

Additionally ,you could check the same scenario by starting the chrome with disabled extensions

from this answer

Run Chrome with the --disable-extensions command-line option to disable extensions. Technically, it doesn’t so much disable all the extensions as much as hide them so that Chrome thinks that none are installed, so this won’t help in your particular case. t_b_b, since you cannot disable extensions in-browser and the command-line argument hides all extensions, what you want to do is to manually disable them. Open your User Data folder then open the file Preferences in a text-editor. Now scroll down to the line starting the settings blocks: "settings": { Each of the extensions will have its own block inside the settings block. To disable them, change their states to 0: "state": 1

To simplify things, just do a search for all lines containing

"state": 1

and change them to

"state": 0

If the above two doesnt work :

Type chrome://flags/#enable-new-video-renderer in address bar and hit enter

restart chrome and view the effect

  • Tried this one but still no improvement. Any other ideas? – rcs Jan 6 '16 at 13:54
  • @rcs updated one more solution,have a look and let me know if it works – BlueBerry - Vignesh4303 Jan 6 '16 at 16:45
  • sad to say but it also does not work.. Are you able to play the video smoothly on your side? – rcs Jan 6 '16 at 23:54
  • @rcs yep,i was able to stream 4k videos properly.the above issue happened to me previously,i solved it by above cases ,let me update u the solution soon – BlueBerry - Vignesh4303 Jan 7 '16 at 4:09
0

YouTube uses the VP9 video codec by default on Google Chrome in the HTML5 player, which is NOT supported for hardware acceleration. You can force Google Chrome to use H264 using the h264ify extension to correct this problem. Blame Google.

https://chrome.google.com/webstore/detail/h264ify/aleakchihdccplidncghkekgioiakgal

Other web browsers do not come with VP9 video codec support default to H264 which can be hardware decoded.

You can use DXVAChecker to see what codecs your video card supports for hardware video acceleration.

Right click on the video itself select stats for nerds to see what codec is being used.

Provided that in about:gpu it shows that video acceleration is enabled, you do NOT need to change anything in about:flags

  • I tried to use the extension but no difference, is there any additional steps that I have to do? – rcs Feb 6 '16 at 12:38
  • This extension removed 4K from the list. – AkiEru May 13 '17 at 11:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.