5

As stated, my M.2 Samsung SM951 NVMe drive refuses to be seen in 3 Ubuntu installations. I've tried (14.04, 15.04, 15.10). Apparently this might be a problem with the SSD as no one online has gotten Linux to recognize it yet.

Windows 10 Pro is currently installed and bootable on the SSD with no problems. I'm trying to set up a dual boot but Ubuntu won't recognize that the drive is even in my laptop.

I have a Dell Precision 7510 laptop with Windows 10 pro pre-installed and fully functioning. I also have a second internal Seagate hdd which is recognized by Ubuntu. I'm booting in UEFI mode with Secure Boot on (I've tried legacy and disabling secure boot to no avail). The Samsung SM951 SSD is recognized in the BIOS and fully functional in Windows but Linux seems to be struggling for some reason. I'm running Ubuntu live from a USB key.

Apparently the Linux Kernel has had NVMe support since 3.3 so that's not the problem. I've been scouring the internet for the better part of a day and I don't think anyone has gotten their SM951 NVMe recognized in Linux. From other forums it seems like it might be a problem specific to this SSD as other NVMe and SSDs work fine in Linux. Does anyone have any ideas?

  • Update: The answers below were the best at the time (although they didn't help me set up a dual boot as it was near impossible at the time). I just got it to work though! Basically my Dell Precision just received a Bios upgrade and Ubuntu 16.04 just released. As mentioned below I had to switch SATA to AHCI, which allowed me to install Ubuntu 16.04 on a separate partition of my NVMe SSD. I then had to boot into windows through safety mode (which automatically installed AHCI drivers or something) then simply rebooted normally. No windows reinstall necessary! Dual boot works now thanks guys – Chris F. Apr 27 '16 at 17:30
8

Complete details on how to install Ubuntu 15.10 on Precision Dell M7510 are reported in this google doc.

Copied below are the main details answering your questions.

Since this is my first post and I don't have at least 10 reputations, only few links are included here.


Disabling SATA mode should allow the disk to be recognized (and bootable) on Linux.

To do so, you will:

  1. Start the computer

  2. Access System Setup by pressing F2 key when you see the Dell logo. See here for details.

  3. Go to System Configuration then SATA operations, and finally change from RAID On to Disabled.

  4. Apply changes and exit.

Notes:

  • Following this suggestion, this is required to ensure the NMVe disk is found during installation.

  • As originally suggested in Dell documentation, specifying boot option nvme_load=YES does not work.


Now here are some comments regarding dual boot with Windows 7 and Ubuntu 15.10.

Considering that:

  • changing the SATA operation mode from RAID On to either AHCI or Disabled prevents Windows 7 from starting. A BSOD (Blue Screen of Death) appears.

  • proposed solution like Registry Fix to Migrate from ATA Mode to AHCI Mode or RAID On Mode in Windows XP, Windows Vista or Windows 7 failed. See http://www.dell.com/support/article/us/en/19/SLN285045

I resumed to install only Ubuntu 15.10.

Notes:

  • Since Ubuntu can be installed with SATA operation set to either AHCI or Disabled, selecting AHCI and doing a fresh install of Windows 7 should work. (I have NOT tested)

  • That said, if you would like optimum performance, disabling SATA Operation and using NVMe protocol is best. The problem is that, as of January 2016, there are no NVMe Windows7 driver for SSD hard drive of type Samsung SM951 (the one installed in Precision M7510). This means that it is not possible to boot or install Windows 7 with SATA operations disabled.

  • A possible workaround is to create a bootable Windows 7 USB disk, by re-using the virtual OS originally bundled with the Window 10 install. The following post provide more details: http://www.tomshardware.com/answers/id-2817439/install-windows-x64-sm951-drive.html#16747080

  • An other option would be to try to use the “950 PRO NVMe Driver” available at http://www.samsung.com/global/business/semiconductor/minisite/SSD/global/html/support/downloads.html

  • Question: If I change to SATA mode to boot linux from a USB stick, then create an image of the Samsung NVMe drive, then change back to RAID On, would I be able to boot Windows? Or would that require a reinstallation. I only need an image of that drive. Thank you – daraos Mar 23 '16 at 14:42
  • @daraos Based on my experiments, switching the SATA mode from RAID On to Disabled (or AHCI) and restoring it back will allow you to boot from the Windows partition without problem. – J-Christophe Mar 25 '16 at 2:50
0

I've found that on a Precision 5510 and 7510, Linux will not see the NVMe SSD if the boot mode is set to UEFI (as in it doesn't even see that the PCI device is present). Changing the boot mode to BIOS, even if you press F12 and actually boot in a UEFI mode lets Linux see the SSD.

Changing the mode will present issues if you've got an existing installation of Windows that you want to keep working though.

protected by Community Jul 1 '16 at 17:53

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.