I have Lotus Notes 9.0.1 running on Xubuntu 15.10 and I can't find a way to open links by just clicking on them.

The default application for links is set to google chrome and it works from within other apps but not from Notes. I always get a popup complaining about a link that can't be opened.

This popup seems to be from Thunar and it complains that it can't open urls like this:


When I hover over the link, I see that there is no "/home/username" in the link, so somehow Notes must add it after clicking on it.

I also tried to set the default file manager to be Chrome and the link that Chrome tries to open is


So again: Notes seems to add "file:///home/username/" to each link I try to open.

When I define that Notes should use the internal browser it works, but it is not my desired behavior.

Any clues how I can change this prefixing behavior of Notes?

2 Answers 2


If you've typed this accurately, it looks to me like the links are mal-formed. I.e., you're showing "http:/hostname/path/site.html", but there should be a double slash after "http:", and you've only got one. The client is noticing that there is not a valid prefix ending in "//", so it assumes it is a file link and is adding a valid prefix - plus it thinks it is a relative path since there is no leading "/" before "http", so it adds the user's home directory as specifice in the environment.

What application is generating those links?

  • I would say it is Notes directly. Within the email, when I hover over the link, I see it written in the bottom bar correctly with http:// Jan 8, 2016 at 15:26
  • Does this happen with all links? If not, there's still the possibility that it's a malformed link but the code that displays it on the toolbar is smart enough to correct it, while the code that handles the click may not be as smart. What does the link look like if you view the MIME source of the message. (Click the 'View' menu, then 'Show', then 'Page Source').
    – rhsatrhs
    Jan 8, 2016 at 15:42
  • So far I haven't found a single link that works and the the link looks like: <a href=3D"https://docs.google.com/a/somethingsomething/document/d/secrethash/edit?usp=3Dsharing_eid&amp;ts=3D568e213=d" ....>Open</a> Not sure why 3D is always before "... I also forwarded that email and I have no trouble opening the link from from my gmail account (via Web-UI). So the link is correct. Jan 8, 2016 at 16:14
  • =3D is actually the "quoted-printable" encoding of the asciii "=" sign, so that's okay - assuming the content-transfer-encoding for the MIME section specifies that. It does look like correct format, and if it works in gmail it should work in Notes. It looks like you've found a bug in the Ubuntu version of the client. If you have IBM support, you should be able to report it.
    – rhsatrhs
    Jan 8, 2016 at 20:06

I've seen this issue in Xubuntu 14.04, and kind of solved it by renaming exo-open (in /usr/bin) to real_exo-open, and by creating a shell-script to replace exo-open, and figure out what to do.

This is a bad solution, because you have to re-do this every time you upgrade your system.

Here's my script:

echo "Called as: $0 $@" >> /tmp/exo-open.log
startswith() {
        [ "${1#$2}" == "$1" ] && return 1;
        return 0;

[ "$1" = "--launch" ] && [ "$2" == "FileManager" ] && {
        startswith $3 ${bad}http && {
                echo "real_exo-open --launch WebBrowser ${arg1#$bad} $@" >> /tmp/exo-open.log;
                real_exo-open --launch WebBrowser ${arg1#$bad} "$@";
[ $launched -eq 0 ] && {
        echo "real_exo-open $@" >> /tmp/exo-open.log;
        real_exo-open "$@";

So basically, if you choose to use this ugly hack, here's what you do:

  1. cd /usr/bin
  2. sudo mv exo-open real_exo-open
  3. cat > /tmp/exo-open
  4. Copy and paste the above script, and end with CTRL-D.
  5. sudo mv /tmp/exo-open
  6. sudo chown root.root exo-open
  7. sudo chmod +x exo-open

And that's it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .