0

I am using a HP-EliteBook 8570w and I have some problems with my touchpad since I installed Windows 10 (64-bit).

If I try to drag something with the "Styk":

enter image description here

then I get a click on every move the cursor makes.

(I can not select text, because I am clicking around).

The problem stays the same for all touchpad-buttons. If I want to open a web-link in a separate tab, it opens this link several time.

The Problem also occurs if i use a button belonging to the Styk itself.

But then it only occurs if i clicked with a normal button before.

With Windows 8.1 everything worked fine. Since I wiped my hard drive and installed Windows 10 I get this error. I tried to install the Windows 8 driver on my windows 10 notebook too, but even that does not work.

The funny thing is that installing a new driver helps sometimes for a short period of time I think (until the next reboot approximately).

The problem is that the behavior is really annoying because it sometimes happens randomly too. The best working driver I think is if I uninstall all and use the default driver of Windows, but then I can not use the scroll function.

I have already asked the HP Support. But they just tell me I should use Windows 8.1 because the notebook is not made for Windows 10.

What can I do here. Can you help me somehow?

  • "because the notebook is not made for Windows 10." there is your answer. If your notebook doesn't support Windows 10 then don't install it. – DavidPostill Jan 7 '16 at 13:14
  • I disagree fundamentally with that answer. "It's not supported" is default answer #1 for the support staffer who doesn't know the answer to the customer's question. CHF, I recommend you investigate whether or not Windows 10 is installing a driver update behind your back that is causing the clicking. Consider looking at the WUShowHide.diagcab file Microsoft provide. – seagull Jan 7 '16 at 13:26
  • thank you @seagull. I will try this "WUShowHide". I think it should be possible to use this touchpad somehow. – CHF Jan 7 '16 at 17:26
  • It still does not solve the problem, but thank you again @seagull – CHF Jan 9 '16 at 10:30
  • 1
    Thank you @seagull. I tried your idea with WUShowHide.diagcab and it works fine with the Windows 8.1 Driver there are no problems anymore. Thank you very very much. - This is what I was looking for. So now I can use my 1.5 year old notebook without problems again. (Sorry for that but... how can I mark your comment as answer?) – CHF Jan 15 '16 at 10:55
0

I have this very same problem in my HP 8570w. Replacing palm rest (buttons and touch pad) did not resolve. My machine went to HP repair center (I got another HP 8570w with the very same problem) and their diagnostic was that this behavior occurs due to a bug in the available driver for Windows 10.
The only reliable way to used the touchpad or stick is to disable buttons and use touchpad click :-(
Until the problem is solved (that is, HP to publish an updated driver that fix the issue), I have to always use an external mouse.

  • I am not sure if this works for you too.. but what I did was this: I disabled updates for the Touchpad with "WUShowHide.diagcab". Then I uninstalled the synaptics software. (if the driver in the device manager is here I removed it too). After (a few - one was not enough) reboots I installed the windows 10 driver available on the HP-support page. and then.. it worked (until now). When i am typing... the touchpad stays disabled for some time so that there are no problems during writing. – CHF Jan 17 '16 at 10:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.