4

I've been dualbooting Windows 7 and Manjaro for about a year now, and I'm getting tired of rebooting every time I want to switch operating systems. I recently heard about the Virtualbox option to run an existing partition in a VM, so I decided to try that. To clarify, I have 4 partitions on the hard drive: Manjaro, a boot partition, Windows and a data partition for windows which contains the User folder, and probably needs to be available on boot.

I created a raw disk image of the whole drive, and ran it in Virtualbox. It got to the boot loader, I chose Windows, and it showed the "Starting Windows" text for about 3 seconds. It then threw a blue screen and shut down. The error code was:

*** STOP: 0x0000007B (0xFFFFF880009B07E8,0xFFFFFFFFC0000034,0x0000000000000000,0x0000000000000000)

When booting normally it works fine. My theory is that it can't find or mount the data partition, and therefore crashes, but I don't know how to check if that is the case, or what to do with it if it is.

So, what is causing this error, and how can I fix it?

  • It sounds like a problem with the RAW image of the HDD honestly. – Ramhound Jan 7 '16 at 17:25
  • What type is the storage controller set to? This particular blue screen can happen when there is no available Windows driver for the hard drive controller (For example, switching from ATA to AHCI in the BIOS without any preparation in Windows). – Jonno Jan 7 '16 at 17:27
  • I tried deleting and recreating the image, but it didn't change anything. I didn't change any of the default settings, except for giving it more RAM – Sindre Stephansen Jan 7 '16 at 17:31
  • The hard drive is on SATA, if that's what you're asking – Sindre Stephansen Jan 7 '16 at 17:32
  • That does not tell us what sort of storage container its set to though. – Ramhound Jan 7 '16 at 18:08
3

The problem is that you only have the intel AHCI driver enable, and not the generic one. So you have to enable drivers that aren't. I don't know which ones particularly but, what I've done for myself worked pretty well except on one case:

  • Go to regedit and go to HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services
  • Find the following folders: aliide, amdide, atapi, cmdide, iastor (may not exists), iastorV, intelide, LSI_SAS, msahci, pciide and viaide
  • Set all their "start" value to 0 in order to enable all theses drivers at boot
  • Save your changes
  • Restart into VirtualBox

If it don't work first, change your SATA controller to an IDE or SCSI one in Virtualbox, that should do it.

If you're still stuck congrats, you're stuck like me. It's an SCSI controller problem from VirtualBox, especially if your BSOD comes from CLASSPNP.sys if you boot in Safe Mode within VirtualBox.

| improve this answer | |
  • This also works for VMware ESXi. I only had to modify LSI_SAS which is the storage controller my VMware VM used. (I also modified intelide but I think LSI_SAS should be the one that nailed it). Thanks! – wandersick May 2 at 8:28
2

Switching from a SATA controller to an IDE controller. For me, fixed the issue.

enter image description here

| improve this answer | |
  • 1
    Thank you for pointing out that detail! Thank you for spending a little of your time to make this answer. I was looking for a solution 4 days now. – hephestos Dec 1 '19 at 23:15
  • This also solved it for me on mac. Thanks for the simple workaround. – h4xnoodle May 20 at 14:50
1

Thank you Fidel seriously, you saved me a lot of grief. I got that stop message issue on my bare metal installation after a motherboard change. Then I plugged everything into my old motherboard and I was shocked when it didn't work. I restored a working backup and I was literally horrified when that didn't work either! It's seemingly the only time this solution's been posted on the internet sans that KB article so thank you very much for this.

If "DisableCDDB" and "DontStartRawDevices" keys are in the 0000001 state simply changing the SATA ports your drives plug into will trigger this issue along with any other hardware changes that cause SATA drivers to be reinitialized. You have to fix the keys in CurrentControlSet (if it exists) and all the ControlSet00X variations Windows has stored by changing the values to 0000000.

[HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\PnP] [HKEY_LOCAL_MACHINE\System\ControlSet00X\Control\PnP]

You don't need a third-party boot disc, you only need your Windows installation disc. Click through all the options it gives you until you can launch a command prompt. Type "diskpart" and then "list disk" to guess where your Windows installation is. Type "regedit" to launch the registry. Highlight "HKEY_LOCAL_MACHINE". Select "File" and "Load Hive". Navigate to Windows\System32\config and load "SYSTEM". Enter a placeholder name once prompted, like "offline hive". Select "offline hive" and now you will be able to modify your registry keys as explained above. When you are done highlight "offline hive" and click "File" "Unload Hive".

| improve this answer | |
  • Nice it helped you. But please, keep answers to a minimum. In this case, delete the thanks and cut down to the details. That makes your answer easier to find and read. – vonbrand Aug 13 '19 at 19:40
0

In some cases, 0x0000007b is caused by a setting which restricts the installation of devices on your computer. It may have been applied by your administrator. Microsoft describes a fix here.

The steps to address the issue are:

  1. Boot Hiren's BootCD in the VM
  2. Run Lazesoft Windows Recovery
  3. Select the windows drive
  4. Repair Tools -> Registry Editor
  5. Open [HKEY_LOCAL_MACHINE\System\ControlSet001\Control\PnP]
  6. Set values to:
    • "DisableCDDB"=dword:0000000
    • "DontStartRawDevices"=dword:0000000
  7. Click the button "Write Changes to Disk"
  8. Restart
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.