1

I am trying to install a program that needs .net 3.5, which is supposed to be build into windows 7 but when I try to activate it in the turn windows features on and off tool it is not there. Downloading the installer just tells me I have to use the dialog I mentioned. I cant find anyone that has had the same problem. I have tried a bunch of tools and hot fixes that all can find no problems. Any other ideas

My system is Windows 7 Enterprise 64-bit

It should be listed right after "Media Features" but it is missing!

enter image description here

  • If that doesn't help. Download a Windows 7 .ISO and add the feature that way. – Ramhound Jan 8 '16 at 0:20
  • I wonder if it has anything to do with being the Enterprise version of W7??? – Moab Jan 8 '16 at 0:31
  • @Ramhound your link has nothing to do with the fact it is missing in Windows Features list and cannot be installed manually. – Moab Jan 8 '16 at 0:41
  • @Moab - I realized that only after I fully read the link. The feature must be manually added back into WinSxS in that case if its missing. – Ramhound Jan 8 '16 at 0:44
  • 1
    @jiggunjer, .net is not like that. a 3.5 app will not attempt to execute on 4.0. the only real exception to that is ASP.net handlers for IIS, which run their pipelines through .net 4, 2, or 1.1. if you run a 3.5 app through IIS, the pipelining is 2.0, but the assemblies loaded are 3.5. – Frank Thomas Jan 8 '16 at 2:22
0

Have you tried to install it by command line?

This should make the trick (disable and re-enable the feature):

DISM /online /disable-feature /FeatureName:NetFx3

DISM /Online /Enable-Feature /FeatureName:NetFx3 /NoRestart

I found this solution here.

NOTE: run command line as Administrator

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.