As I understand the only way I can reformat my laptop which is gpt+uefi by default is if I crate a bootable usb that is also gpt+uefi. However the image file that I have is greater than 4GB and RUFUS says that it cannot be burned to a fat32 usb. I realize that fat32 cannot hold anything larger than 4gb, however I do not intent to put the iso in there as a whole, isn't it supposed to extract it into the usb?

I think it HAS TO be fat32 to work with gpt. Is there anything else I can do other than finding an image file smaller than 4gb?

edit: I found an image file smaller than 4gb it worked fine

  • What you would extract is larger then 4GB currently. What specifically are you trying to burn?
    – Ramhound
    Jan 8, 2016 at 2:01
  • Rufus is not the only tool for creating a bootable USB drive. Most distributions support writing the .iso file to a USB flash drive via dd, as in dd if=imagefile.iso of=/dev/sdc. There are also other tools, like Unetbootin, that might work. One more point: The partition table type (MBR vs. GPT) of the installation medium is mostly irrelevant, so don't worry about that unless your computer won't boot from your medium. (Some are finicky.) The boot mode (BIOS vs. EFI) is important when you're installing, though.
    – Rod Smith
    Jan 8, 2016 at 20:35
  • 3
    "I think it HAS TO be fat32 to work with gpt." That's a common misconception, and it is WRONG. Rufus will happily create an UEFI bootable NTFS drive (through UEFI:NTFS). You should try formatting your drive in NTFS in Rufus and see if that works. Rufus will detect if an ISO contains a >4GB file and set all the options you need to be able to boot it from UEFI for you.
    – Akeo
    Jan 12, 2016 at 11:33
  • There are several workarounds. Basically it's just about creating a small FAT32 partition for UEFI and a big NTFS/ext4/whatever file system for big files. See UEFI Boot a NTFS Drive
    – phuclv
    Apr 17, 2017 at 8:33

4 Answers 4


Rufus developer here. I'm going to try to add a proper answer since there seems to be a lot of misconception about the whole thing. Hopefully, this will help others.

RUFUS says that it cannot be burned to a fat32 usb.

Yes, but if you tried NTFS in Rufus, you would have seen that it does allow you to use that file system, even for GPT/UEFI boot, in which case the issue about the >4GB install.wim goes away.

This is because Rufus relies on an advanced feature, called UEFI:NTFS, precisely to work around this kind of situation. With UEFI:NTFS, Rufus does allow seamless boot of an NTFS partition from a pure UEFI system.

In other words, despite what you may have heard, you are NOT limited to only using FAT32 when booting UEFI. If needed, you can actually boot from NTFS (at least, if you created the drive using Rufus). Plus, Rufus does have logic to detect the presence of a >4GB file in an ISO, and select NTFS by default as the file system when that is the case. So, all you had to do was rely on Rufus to pick the best set of options for you, and just give it a try.

I think it HAS TO be fat32 to work with gpt.

I think you mean UEFI rather than GPT, but, regardless, that's actually a very damaging misconception that is still being very erroneously propagated to this day. I really can't stress this enough: There is absolutely nothing in the UEFI specs that says that it HAS TO boot from FAT32.

As a matter of fact, if you want you can go and purchase any NUC system from intel (as well some systems from other manufacturers), and you'll find that its UEFI firmware will happily boot, in pure UEFI mode, straight from an NTFS partition. So, NO, UEFI does not require FAT32 to work.

The only thing the UEFI specs say is that, at the very least, FAT32 should be supported for boot, but that doesn't preclude other file systems from also being bootable, or utilities, such as Rufus, to work around the possibility that the UEFI firmware's default only includes support for FAT32, and expand on the capabilities of that firmware by adding runtime support for NTFS boot if that is missing.

For more on this, you may be interested in the relevant entry from the Rufus FAQ.

So, to summarize, be mindful about what you hear on the internet about FAT32 and UEFI. Instead, it might be worth to give a little credit to utilities that have been designed, from the ground up, to work around any potential limitations, by testing whether the default configuration they advise you to use might work.

  • The thing is, I am not a partition mastermind or anything. Even though I am somewhat tech literate, all of this looks somewhat of a battle of the alphabet with UEFI NTFS GPT FAT32 etc. Essentially what I am saying is that you should make the program more foolproof. I tried to use a windows10 image that was larger than 4GB a year ago numerous times and I couldnt get it to work. Feb 8, 2018 at 3:18
  • 2
    Did you try to pick NTFS then? If you do and select GPT for UEFI (rather than MBR for BIOS or UEFI-CSM) in Rufus, then I can guarantee that, if your UEFI options are properly configured, and if your firmware does comply with the UEFI specifications, you will be able to boot that drive, even though it contains a >4GB install.wim. Now, one thing you may have to temporarily do is disable Secure Boot.
    – Akeo
    Feb 8, 2018 at 14:02
  • 1
    With regards to your other point, unfortunately, holding the hand of users with regards to this whole process is not something that is feasible: People are already mostly ignoring the DD vs ISO prompt, which is is very straightforward ("Try ISO mode, but if that doesn't work, remember to also try DD mode") and only there to help them, and the main issue here is that there are parameters that the application can simply not guess for you, or even guide you on how to guess them, as they are system dependent. There's too much information that can not be summarized in easily digestible bites here.
    – Akeo
    Feb 8, 2018 at 14:11

The issue for Rufus, and for other burners, isn't that the ISO is bigger than 4 GB typically but a file is bigger than 4 GB in the ISO.

In particular you need to find the install.wim files from the sources directory and then use DISM to chop it up. You then don't even need to use Rufus.

It took me a while to work this out and there are a few steps so I've put the full details at http://blog.next-genit.co.uk/2018/01/how-to-burn-usb-stick-for-uefi-windows.html

NB My advice about Rufus is wrong according to developer so please ignore that part. My way of creating ISOs does work though and FAT32 does have a 4GB limit, but Rufus can work around they say.

  • 3
    "The issue for Rufus (is that it contains) a file is bigger than 4 GB in the ISO". Rufus developer here: that is actually not an issue, since Rufus includes UEFI:NTFS, which allows it to seamlessly handle >4GB files (such as install.wim) in pure UEFI mode. Please look into UEFI:NTFS or simply select NTFS as the file system in Rufus, and try.
    – Akeo
    Jan 26, 2018 at 13:35
  • 1
    Interesting - I agree Rufus has worked for me in the past automatically but having consistent failures on Windows 10 FCU ISO, latest Rufus and Surface Pro 4. I'll put edit on above comment and need to explore some more in Rufus. Jan 26, 2018 at 14:28

UEFI only reads FAT/FAT32 and those do not allow a single file to be larger than 4GB. The solution is to split the large file or to prepare the USB stick with a small FAT32 partition that UEFI recognises and then a larger partition with the installation files. Many ways to do this but here are som explanations:



simply format your boot USB Stick with exFAT which can handle >4GB files fine and will be recognized by UEFI (and BIOS)


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.