I am using VMware Workstation on windows10. I have installed ubuntu14.04 as a guest in VMware.

In ubuntu I have installed Apache. I can access localhost in guest Ubuntu. but I want to access it on the host which is Windows 10's browser.

In VMware I am usinf NAT setting as a network adapter. I have checked several answer regarding the same question but still it is not working.

Here is my settings of VMware

VMware NAT Settings

1

Host ubuntu Ifconfig is

$ ifconfig
eth0      Link encap:Ethernet  HWaddr 00:0c:29:79:ac:c8  
          inet addr:192.168.117.129  Bcast:192.168.117.255  Mask:255.255.255.0
          inet6 addr: fe80::20c:29ff:fe79:acc8/64 Scope:Link

I have tried to access with 192.168.117.129, 192.168.117.1, & 192.168.117.129 but it gives me ERR_CONNECTION_TIMED_OUT

What I am missing. can anyone guide me regarding?

  • Can you ping Ubuntu from Windows 10 ? – pun Jan 8 '16 at 7:05
  • actually not. it says request timeout. – Alpha Geek Jan 8 '16 at 7:16
  • It must be the firewall in Ubuntu. Try sudo ufw disable and see if you can ping and access localhost – pun Jan 8 '16 at 7:19
  • still not working! – Alpha Geek Jan 8 '16 at 7:22
  • I pinged 192.168.117.129 and 192.168.117.2 both. – Alpha Geek Jan 8 '16 at 7:50
up vote 0 down vote accepted

The Missing part in the Image I can see your host is not connected.

you need to connect it by checking the checkbox.

enter image description here

After that when you access 192.168.117.129 from the browser on your host it will definitely work!

  • Not sure if this is enough to have it working. You have to delete the port forward setting (or change it - see below). The NAT port forward is only needed if you want to have access to this apache on the VM from other hosts in your network. The change mentioned would be to enter the correct IP of the VM instead of 127.0.0.1 - so in your case 192.168.117.129. – Zina Jan 8 '16 at 8:50
  • OK. It will work. The NAT rule just does not make sense and is not needed (except the case mentioned above - so you would be able to access the web server from other hosts through the host IP where your workstation is running). – Zina Jan 8 '16 at 9:33

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.