1

I have built a Linux based router for a network testing environment. The machine has 4 physical ethernet ports

  1. wan
  2. lan0
  3. lan1
  4. lan2

All 3 lan* interfaces are bridged on my lan device. I am running dnsmasq to provide DHCP/DNS on the lan interface. I am trying to use SLAAC IPv6 addresses instead of DHCPv6 assigned addresses and am using DHCPv6 for other information (so stateless DHCPv6). All other computers on my lan correctly assign themselves addresses via SLAAC. However even though dnsmasq is sending router advertisements on the lan interface my wan interface is somehow seeing it and autoconfiguring itself. I have run wireshark on my wan interface and there are no incoming router advertisements actually coming over the network.

I have even tried turning off slaac on my wan interface by setting the net.ipv6.conf.wan.autoconf key to 0 via sysctl but it still gets an address.

Is there any other way that this could be happening.

  • I'm under the impression that a host will undergo stateless configuration for a network prefix if and only if the router advertisement has an option block for this network prefix where the 'A' flag is set. Can you confirm that in your RA message (icmpv6.type=134), the option block corresponding to the /64 network for which you get a SLAAC address has it == '0' (unset)? Is your wan interface running a dhcp6 client to get a prefix from upstream (e.g. dhcpv6-PD)? – init_js Sep 6 '16 at 4:52
0

The problem turns out not to be network or kernel related but rather related to systemd running on this system. systemd-networkd isn't filtering the multicast messages related to router advertisement appropriately or respecting the sysctl values for turning slaac off for a interface. So it was processing the RA and adding the IP itself.

  • How did you fix it? – John Oxley Mar 3 at 22:55

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.