1

At first I noticed that I can't access Computer Management using the context menu of "This PC" icon in desktop (nothing happens if I click the "Manage" option in the menu); although I can access it using the search option of taskbar or administrative tools in control panel.

After some research I found out (from here, although not sure at that time whether it will be effective though) that changing a registry value can be a probable solution for the problem.

So, I opened regedit and there I searched for CompMgmtLauncher.exe; found it somewhere like Computer\HKEY_CLASSES_ROOT\CLSID\{20D04FE0-3AEA-1069-A2D8-08002B30309D}\shell\Manage\command - then changed the value from %SystemRoot%\System32\CompMgmtLauncher.exe to %SystemRoot%\System32\compmgmt.msc /s.

After that, when I try to access Computer Management using the context menu of "This PC", I get the following error.

Error accessing compmgmt.msc from context menu of This PC

What can be done at this stage to make Computer Management accessible using the context menu of "This PC"?

P.S- If I manually access %SystemRoot%\System32\, then try to run CompMgmtLauncher.exe - then nothing happens; but if I run compmgmt.msc (which is located in the same location), Computer Management window opens.

  • 2
    Obviously you should change it back. – Ramhound Jan 8 '16 at 15:58
  • CompMgmtLauncher.exe in a command folder can be found several places in the registry that should be checked, skip muiCache locations. – Moab Jan 8 '16 at 16:13
  • 1
    %SystemRoot%\System32\CompMgmtLauncher.exe is the default data for each of them. – Moab Jan 8 '16 at 16:15
  • @Ramhound : yes, I can change it back - but that is not going to be helpful for me; as the previous registry setting did not work the way it should at the first place. – Muntasir Jan 8 '16 at 16:43
  • 1
    Well the parameter you are using is invalid hence the error message you received in the screenshot. – Ramhound Jan 8 '16 at 16:48
0

The reason why this can stop working is because CompMgmtLauncher.exe is launching either Server Manager (on Windows Server) or Computer Management (on Windows Client), and it is doing so by launching a shortcut to the proper tool, which should be located in FOLDERID_CommonAdminTools which according to Microsoft Documentation is:

%ALLUSERSPROFILE%\Microsoft\Windows\Start Menu\Programs\Administrative Tools

You should have Computer Management.lnk in there pointing to the appropriate MMC snap-in (or Server Manager.lnk on Windows Server) in order for CompMgmtLauncher.exe to do anything at all.

If you deleted Computer Management.lnk you can either extract it from the sources\install.wim file in the Windows ISO image using 7-Zip, or manually create it with the following parameters:

Target: %windir%\system32\compmgmt.msc /s

Start in: %HOMEDRIVE%%HOMEPATH%

Comment: Manages disks and provides access to other tools to manage local and remote computers.

Icon: %windir%\system32\Mycomput.dll

Icon settings

-1

Buggy shell extensions can cause such problems, and the excellent ShellExView can be used to narrow down the problem. http://windowsxp.mvps.org/slowrightclick.htm

Although the page doesn't mention about "Manage" verb blocked by a shell extension, the instructions are worth a try.

  • Feel free to explain how the program works and should be used to solved this problem. – Ramhound Jan 9 '16 at 1:43
-1

I still had this issue after optimizing Windows 10 LTSB.

Here is the fix:

  • Open regedit
  • Go to "Computer\HKEY_CLASSES_ROOT\CLSID{20D04FE0-3AEA-1069-A2D8-08002B30309D}\shell\Manage\command"
  • Right-click on "command" key -> Permissions -> Advanced
  • Change the Owner to your user
  • Add your user to "Permission entries" with "Full Control" permissions
  • Close Permissions window
  • In "command" key modify the "(Default)" string

from: %SystemRoot%\system32\CompMgmtLauncher.exe

to: mmc.exe %SystemRoot%\system32\compmgmt.msc

  • Close regedit
-2

Actually, most times this Manage- right click problem has nothing to do with the context menu and is caused by the Disk Management snap-in when it hasn't been loaded into the system yet. When you right click Manage Win 10 sometimes doesn't load the snap-in & nothing happens.

Why? well I guess Modern coding may be a bit sloppy these days and because of this win 10 is lazy & forgets..

Try Typing this into the Run command: compmgmt.msc. EDIT: I'm just as bad as windows 10 because I previously wrote the wrong run command, but It's the correct one now.

This command will load the snap-in into windows & the "This PC right click- Manage" should work from now on.

Here is a list of other run commands to get things up & running when they suddenly get Lazy:

 azman.msc : Authorization Manager snap-in

 certmgr.msc : Certificate Manager 

 comexp.msc : Component Services Manager

 compmgmt.msc : Computer Management 

 devmgmt.msc : Device Manager

 diskmgmt.msc : Disk Management

 eventvwr.msc : Event Viewer 

 fsmgmt.msc : Shared Folders Management

 gpedit.msc : Local Group Policy Editor 

 lusrmgr.msc : Local Users and Groups 

 NAPCLCFG.MSC : NAP Client Configuration

 perfmon.msc : Reliability and Performance Monitor 

 printmanagement.msc : Print Management

 rsop.msc : Resultant Set of Policy 

 secpol.msc : Local Security Policy 

 services.msc : Services (Snap-in) non-DLL based

 taskschd.msc : Task Scheduler 

 tpm.msc : Trusted Platform Module (TPM) on Local Computer

 WF.msc : Windows Firewall with Advanced Security on Local Computer

 WmiMgmt.msc : WMI Control (Local) 

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.