0

This is an email I sent to the ASRock motherboard company's support email address. My motherboard will power my heatsink fan, my led's, the powerbutton, and even my SSD. I am getting no output from the HDMI or VGA slots though, and if no memory is installed I get no error beeps from my motherboard. I have taken the battery out overnight, and shorted the CMOS. Any help on what I'm missing?

"Motherboard : FM2+a88x- ITX+ APU: A10-7870k Quad-Core, integrated graphics CPU from AMD Memory: 12gb (8 + 4) GSkill 1600 Video Card: Integrated on CPU Operating System: none yet Hard Drive : Silicon Power 250gb Bios : 2.50

When I have every single cord plugged in and ram modules in (I've tried just one module in each slot) the cpu heatsink fan will spin and the power supply fan will spin. The motherboard gives no beeps when memory is not in, and I have the speaker plugged in. I've reseated everything three times, but I get no video output. I've used HDMI and VGA. Is it possible that I get no beep codes because the APU isn't directly supported until bios 3.0? If so can ASRock update my bios due to the fact that I can't boot to flash it? Any insight would be extremely helpful!"

  • Have you tried the monitor setup before (VGA connector and monitor). – E2Busy Jan 8 '16 at 19:11
  • @RACING121 No, but I don't even get a post error beep, so would it even be relevant? – Coleman Tyler Jan 8 '16 at 20:17
  • If the motherboard isn't even attempting to POST I would RMA it immediately. – Ramhound Jan 9 '16 at 2:12
  • That's what I'm going to do! Awesome, thanks everybody! – Coleman Tyler Jan 9 '16 at 2:14
2

If you're sure the speaker is functioning and attached to the motherboard properly, and you remove all the RAM and get no beeps, then your board is not performing its POST.

The minimum components you need to POST (in most cases) is a PSU, a motherboard and a CPU. If you remove everything except PSU, Mb and CPU and you still get no POST then I'd say either your motherboard (more likely) or CPU (much less likely) are faulty, and need to be replaced.

You may want to try a known-working PSU first, just because it'll be easiest to try, and will eliminate the PSU as a potential problem.

But everything you're describing sounds like a faulty motherboard to me.

Now, if this configuration NEVER worked, and you suspect that it's because your current BIOS revision doesn't support a newer CPU, then that could very well cause it. The usual way to fix that is to install a compatible CPU, update your BIOS, and then install the newer CPU.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.