0

I just built a PC (hardware listed below) and when it starts up, it is fine. The standard Windows 10 desktop task bar at the bottom will show up, and the start menu can be used. However, the icons (eg. the Recycling Bin shortcut) do not show up on the screen.

Right-clicking the desktop brings up the standard menu, but when I click the "Display Settings" Button, it opens up - apparently - and shows up on the task bar. In fact, I can hover over the spot on the task bar and it will show the small preview window. But it does not show up on the screen itself. No window of any application, not even the control panel, will show up on screen except the start menu.

The computer was only just built and I need to install a number of drivers (which is probably the cause of the problem) but I can't see the installers, or even the File Explorer window to start the installers. So my question is: how do I get the computer to at least show me the windows so I can finish installing driver? Thanks for any help.

Hardware:

  • GPU: Nvidia EVGA GeForce GTX 970
  • OS: Windows 10, 64-bit
  • An Asus display (Sorry I can't find the model)

In case it is relevant, the display will crash/disconnect after about 3 minutes of being on, but I think this will be fixed once the drivers are all up and running

5
  • What happens if you start in "safe mode"?
    – DavidPostill
    Jan 9, 2016 at 10:29
  • Thanks fro replying, but it turns out that the computer thought it was connected to 2 screens and it was only showing me the right screen.
    – DJpotato
    Jan 9, 2016 at 12:07
  • So you fixed it then? Please read Can I answer my own question?. You might want to convert your comment into an answer ;)
    – DavidPostill
    Jan 9, 2016 at 12:09
  • Thanks. If u have the time, I'm going to post my crashing/disconnect problem as a question, is it alright if I link you to it?
    – DJpotato
    Jan 9, 2016 at 12:20
  • Please don't. I see all new questions anyway. If it looks interesting I will read it. If I read it and can answer it I will.
    – DavidPostill
    Jan 9, 2016 at 12:26

1 Answer 1

1

I solved this by having a random thought, if anyone has a similar problem:

  • Right click on the desktop, click "Display Settings".

  • Follow option C at http://malektips.com/windows-7-move-off-screen-hidden-window-application.html#.VpD2X4TiNFI with your settings window.

  • If you have the same problem as I did, then under the drop down menu 'Multiple Displays' it will say 'Extend these displays'. Instead you only want 'Show only on [number of your screen]' If you aren't sure what screen number, try all of them - if your screen goes black wait a few seconds and it will reset.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .