I am trying to give myself write access to several directories in samba shares. However, I am only partially successful and I cannot figure out why this does not work... Lets say I am user username and I have three folders folder1, folder2 and folder3. I can touch all of the files on my local machine under the account username, in particular I have set the following permissions:

chown -R username:users {folder1,folder2,folder3}
chmod -R 755 {folder1,folder2,folder3}

I now added the following sections to smb.conf:

  path = folder1
  writeable = yes
  browseable = yes

(and the same for folders 2 and 3). I restarted smbd and tries to access the shares remotely. I used nautilus for this and entered the credentials of username. I can see the three folders and I have full read access to everything. However, as soon as I attempt to touch a file using the shell or copy files to the share I get Permission denied errors. However, I only get them for folder1 and folder2, in folder3 everything works perfectly. I can't figure out what prevents me from writing to the other folders. Does anyone have any ideas at all?


If you have any configuration lines that look like they are simply placed after the blocks, the result may be that the configuration line(s) are actually affecting just the last block.

In my actually-working Samba configuration, I have this in each block:

comment = location to store files before they are moved to blockname
path = /srv/blah/blockname
public = yes
writable = yes
valid users = smbuser _smbuser root

Note: I have it spelled as "writable", not like your sample of "writeable". (However, according to the man page for smbd.conf, it looks like either works, and both are synonyms for acting in the opposite way of a "read only" option.)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.