18

I have a Sengled lightbulb - bluetooth speaker (Pulse Solo C01-A66) that I paired with my Win 10 computer, but I can't get the computer to send the music signal to the speaker. What do I need to do to listen to music on it? The speaker works fine with my Android phone.

  • I don't have 10 rep here, but i do have an answer. Root cause: BT device provides 2 services -- stereo and hands-free. By default Windows will use hands-free as a main. Disable that (Start - Settings - Sound (left) - Sound control panel (right) - Playback tab - (Whatever your hands free device is) - Properties - Device usage (bottom) - Don't use this device (disable). After that you may need to disconnect and reconnect your BT headset. – Andrey Lebedenko Mar 3 '19 at 17:53

15 Answers 15

16
  1. Go to Device Manager > Bluetooth > Microsoft Bluetooth emulator (mine also had an LE enumerator)

  2. Go to action up top and click disable - mine was the LE one that had to be disabled.

Ignore the warning and it will work. The sound now comes from my Bluetooth speaker.

| improve this answer | |
  • 1
    This does nothing for me. – kleinfreund Dec 16 '16 at 8:08
  • 4
    after disabling the "Microsoft Bluetooth LE-Enumerator" it worked for me. (Hadnt to disable anything else) – InsOp Nov 24 '18 at 13:17
  • 2
    This is the only answer that helped me... Just disabled the "Microsoft Bluetooth LE-Enumerator" and paired the headphones and it worked – lewis4u Jan 1 at 12:27
7

How to troubleshoot: "Bluetooth speaker connected but no sound"

But before you start troubleshoot this issue, have you make sure to set your Bluetooth Headset as default play back device, while the media player( which ever you're using) was running? Also, have you read the user manual? That can be somethimes very useful!

After a short google search I found the following methods:

Method 1:

Check if the Bluetooth service is running:

  1. Press Windows Key + R, type services.msc and press Enter.
  2. Search for Bluetooth support service.
  3. Check if it is started, if not Right click on the service and click on Start.

Method 2:

Reinstall the Bluetooth driver following these steps:

  1. Press Windows key + X and select “Device Manager”
  2. Expand “Bluetooth” and right-click on the driver.
  3. Select “Uninstall”, check marked “delete the software for the device” and select “OK” (after that, you can see there is no “Bluetooth” expansion on "Device Manager")
  4. Select “Update Driver Software”.
  5. Restart the computer.

Method 3:

Restart Bluetooth wireless connectivity:

  1. From the Start screen, swipe in from the right edge of the screen, and then tap or click Settings.
  2. Tap or click Change PC settings.
  3. Tap or click PC and devices, and then tap or click Bluetooth.
  4. Under Bluetooth, tap or click to turn Bluetooth Off, and then tap or click again to turn Bluetooth On.

Furthermore, here are some useful links (and sources to this answer):

| improve this answer | |
  • 3
    None of the above methods did anything for me. My bluetooth device isn't listed under sound devices. Interestingly: Under Control Panel → Devices and Printers → my device, opening Properties → Services produces an empty list. Hence I can't enable/disable anything – kleinfreund Dec 16 '16 at 8:16
  • 3
    Method 3 worked for me with JBL Charge 3. It paired and played just fine initially, but then it stopped working after I wanted to send a file from phone to the same computer via bluetooth. I turned off the speaker and turned back on after I was done. Hit the bluetooth button on speaker, and it was not connecting. The "Manage Bluetooth devices" window (Win 10) stated that it was paired but nothing was happening. Simply switched bluetooth off and then on again in the same window, and it worked immediately. The speaker status in the window changed from "paired" to "connected". – StormRyder Jan 8 '17 at 3:27
7

none of this works because Windows fails to assign an appropriate driver TYPE to the Bluetooth speaker by default.

Here's how to fix!!!

About my setup - I am using a business laptop HP ProBook 650 G1 with Windows 10 x64, but this fix should work on any Windows.

  1. All you need is the standard Bluetooth drivers and wireless drivers provided by the manufacturer of the laptop on their website, but make sure you have the latest one!
  2. Power on the speaker (I have a JBL Charge 3)
  3. Press the Bluetooth button on the speaker - the power button starts blinking blue
  4. Go to the usual place where you add a new Bluetooth device (for Windows 10 that's Windows Settings > Devices > Bluetooth)
  5. Connect/pair with the speaker - the power button changes color to white and is not flashing, Windows says device is connected/paired, but can't play any sound
  6. Go to Control Panel > Device Manager > expand Bluetooth > right click JBL Charge 3 (or your BT speaker) > Properties > tab Driver > Update Driver... > Browse My Computer For Driver Software > Let Me Pick From a List...
    • You probably see that Windows has assigned a driver for generic "Bluetooth Device", which will never work because the speaker is programed as an audio device/headset
  7. Untick "Show Compatible Hardware"
  8. On the left choose "Microsoft" and on the right choose "Handsfree Audio Gateway Service" and click Next
  9. You will receive a warning that Windows cannot confirm the comptability but that's ok, click Yes and close everything
    • Speaker power button is still showing white, when it connects it will show blue
  10. Go to Control Panel > Devices and Printers (not Device Manager!) > right click JBL Charge 3 (or your BT speaker) > Properties > tab Hardware
  11. You will probably see a few entries, one of which is "Bluetooth AV", highlight it and click Properties
  12. tab Driver > Update Driver... > Browse My Computer For Driver Software > Let Me Pick From a List...
  13. This time you should see two entries: "Bluetooth AV" and "Bluetooth Stereo", choose "Bluetooth Stereo", click Next and click Yes if asked anything
    • at this point you should hear the speaker making a sound, the power button lights in blue, and you have a new entry in the Playback Devices (the speaker should become the default one as it will be recognized as a bluetooth headset device)

If the above doesn't work for you, then you probably need different choice of drivers. Try "Headset Audio Gateway Service" instead.

I am so happy I finally fixed it, it took me two evenings to figure it out (facepalm)

Hope it works for you, too! Enjoi (:

| improve this answer | |
  • Please do not post the same answer to multiple questions. If the same information really answers both questions, then one question (usually the newer one) should be closed as a duplicate of the other. You can indicate this by voting to close it as a duplicate or, if you don't have enough reputation for that, raise a flag to indicate that it's a duplicate. Otherwise tailor your answer to this question and don't just paste the same answer in multiple places. – DavidPostill May 2 '17 at 22:42
  • 1
    This was the only thing that worked for me with an echo – Steve Ford Apr 4 '18 at 11:57
3

The missing step is to click on the Speaker icon in the "System Tray" (is it still called that?) at the bottom right corner of the screen. Above the volume slider is the name of the current output device, and to the right of that name is a ^ which you must click to select your Bluetooth device. This worked for me.

| improve this answer | |
  • This is really a comment and not an answer to the original question. You can always comment on your own posts, and once you have sufficient reputation you will be able to comment on any post. Please read Why do I need 50 reputation to comment? What can I do instead? – DavidPostill Jan 16 '17 at 23:22
  • 3
    Really? I had the same issue as the OP and the steps I describe solved the issue. To me that makes it an answer to the original question. – intDattashame Jan 17 '17 at 19:50
  • "The missing step" makes it an incomplete answer and therefore a comment. What are the rest of the steps? – DavidPostill Jan 17 '17 at 21:34
  • 2
    The step the OP already performed - pairing the device to the computer via BlueTooth, – intDattashame Jan 21 '17 at 14:35
  • Yep, this fixed it. Now I just need to figure out how to get it to work through realtek. – Byte11 Nov 25 '17 at 19:49
1

I had all sorts of problems with this.

My symptoms:

  • Sometimes just no sound, and very long wait for connect or disconnect
  • No sound when muting speaker then unmuting
  • Windows Audio Device Graph Isolation consistently used 20% CPU when connected

Solution:

  1. Right click speaker icon in system tray (bottom right) Open Playback Devices
  2. Right click any device and make sure you are showing disconnected and disabled devices
  3. There should be two speakers Headset Earphone and Speakers, both say your device name Charge 3 underneath.
  4. Make sure to right click, disconnect Headset Earphone and optionally disable it after so it won't reconnect.
  5. Seems like you have to disconnect the microphone too, otherwise Headset Earphone reconnects and no sound.

All should hopefully work for you after that :) Fast connections, sound, and mute all works now!

Seems like a bug with the drivers, as of right now it looks like you can't use the mic and speaker for voice calls, have to use another mic while using these speakers. May have to contact JBL or Microsoft to report the issue.

| improve this answer | |
  • If any of you still have Windows Audio Device Graph Isolation CPU problems, disable the enhancements on the devices you are currently listening to. Here is a helpful How To howtogeek.com/273764/… – Mr_Moneybags Mar 9 '17 at 23:18
0

I had to download this driver: https://www.broadcom.com/support/bluetooth to make it work.

| improve this answer | |
0

There is one step you all are missing. After making sure the bluetooth speaker or headphone is paired with your computer and ready to connect open the windows 10 action center and you will see a panel that says.... connect. Click on that. Windows will search for your bluetooth device and ... connect to it.

| improve this answer | |
0

I had this happen to me. I had to go to Settings > Devices > Bluetooth > More Bluetooth Options, then make sure the Allow bluetooth devices to find this PC is checked.

| improve this answer | |
0

Based on what @svinec said and despite Windows 7 not supporting Bluetooth 4.1 (my motherboard supports it), I updated my drivers from the Asus website, 'updated' the driver for the 'Generic Bluetooth Adapter' to 'Qualcomm Atheros QCA61x4A Bluetooth 4.1', rebooted, installed the Asus drivers again and rebooted.

At this point I could see my JBL Charge 3 was showing blue, so it was now paired (before it would pair, but only show white). I removed the device, re-paired it and under playback devices in 'Sound' I found 'Speakers' listed as a 'Bluetooth Audio Device'. I set it as the default and sound now plays from the device.

| improve this answer | |
-1

To make bluetooth headphones appear as a Playback Device: I went to Control Panel, Hardware and Sound, Devices and Printers, right clicked my headphones, click Properties tab, click Services tab, check box for Audio Sink To Activate my headphones: Right click the speaker/sound icon in the bottom right menu, select Playback Devices, right click my headphones, check enable, click OK

Works great. Done. Trick was finding my headphones under Devices and Printers as previous poster mentioned - Thanks svinec. Glad I did not have to do as many updates as you, but also glad we both got our headphones working, thanks again!

| improve this answer | |
-1

I had this happen to me. I had to go to Settings > Devices > Bluetooth > More Bluetooth Options, then make sure the Allow bluetooth devices to find this PC is checked.

| improve this answer | |
-1

A possible solution to Bluetooth speaker playback issue:) I tried all the steps listed in several posting forums with no success. I finally found a solution after 3 hours of investigating. 1st several forums suggest updating drivers... but do not specify which drivers to update i.e. the Bluetooth device? (eg. bose audio, sony driver for sony Bluetooth headphones etc.), or the windows driver?

*** For me the solution was updating the Bluetooth driver from LENOVO's website (the laptop/computer manufacture's website) once the driver was installed the bluetooth playback through BOSE Bluetooth audio adaptor worked perfectly.

I understand not everyone will have a LENOVO laptop/computer however I think it is worth downloading the latest Bluetooth driver from the device you are streaming from.

Hope this helps!

| improve this answer | |
-1

Here is another possible reason why someone could have this kind of a problem... In my case, I was using the DFX Audio Enhancer.

After I had set my Bluetooth speaker as a default audio playback device and started playing a song, I noticed on the control panel for Playback Devices (and heard with my ears, of course) that it still played through the laptop speakers. I tested the Bluetooth speaker under Properties, and everything was OK. Then I tried turning Bluetooth on and off, and then the DFX, but it still played back through the laptop speakers.

Finally, I went to the DFX menu and saw a "Playback Devices" option, under which I had speakers and the Bluetooth speaker. I selected the Bluetooth speaker, and it finally worked. So, it may be that you're using some sort of an audio enhancement/processing program that does audio device routing you may be unaware of.

| improve this answer | |
-1

This could be a very specific me, but I was having this issue and it turned out that I was connected to a voice channel in my discord, not speaking to anyone, but this stopped the sound coming through my headphones. This probably has something to do with the hands-free function with my headphones (Sony MDR-1000X) As soon as I disconnected from the call my headphones were working again.

| improve this answer | |
-1

What worked for me is I went into my device manager, completely uninstalled my Bluetooth device, and then reconnected. It worked for the first few days and then stopped, nothing worked to make it function properly again until this.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.